BlueWave Studio forum
Wireless AA after Android 11 update, OnePlus phone - Printable Version

+- BlueWave Studio forum (https://bluewavestudio.io/community)
+-- Forum: OpenAuto Pro (https://bluewavestudio.io/community/forumdisplay.php?fid=86)
+--- Forum: Android Auto (https://bluewavestudio.io/community/forumdisplay.php?fid=79)
+--- Thread: Wireless AA after Android 11 update, OnePlus phone (/showthread.php?tid=2664)

Pages: 1 2


Wireless AA after Android 11 update, OnePlus phone - andyltu - 05-19-2021

Hello All,

So first thing I should mention, I think it's not the OAP problem but the phone and AA in general. Anyway, I'm posting this here with hopes that someone has a solution for this.

My setup:
OAP 13 (tried 12 as well) 
Raspberry pi 3b+
Generic USB SoundCard
AA via 5Ghz hotspot
Oneplus 7 Pro 


I'm using AA wireless with standard connection method. issues started after I've upgraded my phone. When I've upgraded it to Android 11, AA was updated as well. Since then, I was able to launch AA wireless like 3 times (out of about 100).

Seems that issue is that when you try to start AA Wireless, phone start the connection, you can even see black screen of AA launch (that short app switch back and forth), but just after that phone disconnects from the RPi hotspot and thus fails to connect to OAP because of the timeout. After 5-10 seconds phone connects back to the RPi hotspot, but it's too late and AA is not working. That happens every time.

I've tried to switch on and off various options mentioned in the https://bluewavestudio.io/community/showthread.php?tid=1540 post, but that didn't help.

One thing I can mention that AA Debug server + connection via IP works fine (I hear sound cracking, but I haven't checked maybe pusleaudio cfg has been changed after the OAP update). I suppose it's logical that it works, because initiation procedure is different and phone does not disconnect from the hotspot.

Has anyone encountered such issue of hotspot disconnect during AA initiation and maybe even found a workaround for it?


RE: Wireless AA not working after Android 11 update - madsvodder - 05-19-2021

Exactly the same problem i have. I have a oneplus 7 pro too. Mine ONLY works with cable...

EDIT: It works by IP


RE: Wireless AA not working after Android 11 update - BlueWave - 05-19-2021

As a first shot, please try to disable any battery optimization for the Android Auto app. OnePlus devices are known to have very restrictive and buggy battery saving implementation. More details can be found at https://dontkillmyapp.com/ and https://dontkillmyapp.com/oneplus


RE: Wireless AA not working after Android 11 update - madsvodder - 05-19-2021

(05-19-2021, 06:54 PM)BlueWave Wrote: As a first shot, please try to disable any battery optimization for the Android Auto app. OnePlus devices are known to have very restrictive and buggy battery saving implementation. More details can be found at https://dontkillmyapp.com/ and https://dontkillmyapp.com/oneplus

This sadly doesnt change anything Sad


RE: Wireless AA after Android 11 update, OnePlus phone - gecko242 - 05-20-2021

Exactly the same problem here. OP7 Pro, Android 11. Wireless AA broke after the Android 11 update, so I think its AA at fault rather than OAP. Either way, if anyone has a solution that would be great!


RE: Wireless AA after Android 11 update, OnePlus phone - BlueWave - 05-20-2021

Does it change something when you download Android Auto APK file from e.g. APK mirror and install it manually?

https://bluewavestudio.io/community/showthread.php?tid=1748


RE: Wireless AA after Android 11 update, OnePlus phone - andyltu - 05-20-2021

I've tried turning off baterry optimisation off as well, didn't help.

Regarding apk from third party sources, no luck there as well, at least for me. As now AA comes pre-installed with android, with Android 11 base installed version got much newer. So when you try to uninstall and install from apk it only let's you install a newer version than the base that comes with os (at least from my experience). Sadly all the version I've could try were much newer than I've used before and had the mentioned issue.


RE: Wireless AA after Android 11 update, OnePlus phone - BlueWave - 05-20-2021

(05-20-2021, 12:38 PM)andyltu Wrote: I've tried turning off baterry optimisation off as well, didn't help.

Regarding apk from third party sources, no luck there as well, at least for me. As now AA comes pre-installed with android, with Android 11 base installed version got much newer. So when you try to uninstall and install from apk it only let's you install a newer version than the base that comes with os (at least from my experience). Sadly all the version I've could try were much newer than I've used before and had the mentioned issue.

It is not matter of the version. When you are installing an APK file it will wipe and re-create all application data. This process differs from wiping data/cache in Settings. We suggest anyway to download the latest APK and install it on the phone. Please have a look at this thread https://bluewavestudio.io/community/showthread.php?tid=1748


RE: Wireless AA after Android 11 update, OnePlus phone - madsvodder - 05-20-2021

(05-20-2021, 12:53 PM)BlueWave Wrote:
(05-20-2021, 12:38 PM)andyltu Wrote: I've tried turning off baterry optimisation off as well, didn't help.

Regarding apk from third party sources, no luck there as well, at least for me. As now AA comes pre-installed with android, with Android 11 base installed version got much newer. So when you try to uninstall and install from apk it only let's you install a newer version than the base that comes with os (at least from my experience). Sadly all the version I've could try were much newer than I've used before and had the mentioned issue.

It is not matter of the version. When you are installing an APK file it will wipe and re-create all application data. This process differs from wiping data/cache in Settings. We suggest anyway to download the latest APK and install it on the phone. Please have a look at this thread https://bluewavestudio.io/community/showthread.php?tid=1748

This doesnt work for me. It cant even install the APK.


RE: Wireless AA after Android 11 update, OnePlus phone - BlueWave - 05-20-2021

(05-20-2021, 01:24 PM)madsvodder Wrote: This doesnt work for me. It cant even install the APK.

If you can't install APK how do you know that it does not work?