Current version of the OpenAuto Pro is 13.1
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to use new Wireless Android Auto feature
As of version 7.0 OpenAuto Pro supports Wireless Android Auto connection that does not need Head Unit Server enabled on the phone. This feature is now experimental and it is disabled by default. In order to use it below preconditions must be fulfilled:
  • Wireless Android Auto option has to be enabled in Settings → Android Auto → System
  • Phone has to have Bluetooth connection established with the Raspberry PI
  • Wireless Hotspot mode has to be enabled (default password: 1234567890) or external wireless network credentials have to be provided in openauto_system.ini file (
  • It might be necessary to enable Wireless Projection in Android Auto application settings on the phone
Once all preconditions are fulfilled, Wireless Android Auto connection can be triggered by clicking Wi-Fi tile at Android Auto menu. Also wireless connection will be automatically triggered once Bluetooth connection between phone and Raspberry PI is established (this behavior can be disabled by disabling Start Android Auto automatically option in Settings → Android Auto → System).

In order to improve performance of the wireless connection, we strongly recommend to use 5GHz mode.

YT movie:

I think the original requirements list should be updated to be a much more detailed how to list.
  • Wireless Android Auto option has to be enabled in Settings → Android Auto → System

  • Phone has to have Bluetooth connection established with the Raspberry PI

  • Wireless Hotspot mode has to be enabled (default password: 1234567890) or external wireless network credentials have to be provided in openauto_system.ini file.

  • It might be necessary to enable Wireless Projection in Android Auto application settings on the phone
Detailed instructions.

  1. OAP - Enable Wireless Android Auto option has to be enabled in Settings → Android Auto → System
  2. OAP - (Optional) While in the screen from step 1 enable "Start Android Auto automatically"
  3. OAP - Wireless Hotspot mode has to be enabled (default password: 1234567890) or external wireless network credentials have to be provided in openauto_system.ini file.  Enabled in Settings → Wireless Settings
  4. OAP - (Optional) While in the screen from step 3 it's recommended to set the Hotspot Band to 5 GHz to reduce interference and improved bandwidth.
  5. RasPi - Ensure Bluetooth is enabled in your RasPi wireless settings, it should be enabled by default unless you disabled it.
  6. Phone - Connect your phone to the OAP system via Bluetooth ensuring to allow it to have access to your contacts
  7. Phone - Make sure Android Auto has wireless projection enabled.  AA on your phone → Settings → near the bottom is a "Wireless projection" area toggle on "Enable wireless projection."  If this area exists skip to step 9 if it doesn't do step 8.
  8. Phone - If Wireless projection is missing from AA you have to enable it.  AA on your phone → Settings → tap Version 10 times until it says Developer Settings are enabled.  Click the 3 dopts in the top right and enable "Add wireless projection to settings."  Back out of the menu and force close AA (not just exit but you have to force close it either by swiping it away in a task list or going into app settings and closing it.)  Reopen AA on your phone → Settings → and follow the instructions from step 7.
  9. Phone - AA on your phone → Settings → Phone screen settings → Autolaunch and enable it and check enabled for OpenAuto-Pro which was established in step 6.
  10. Phone - (Optional) While in the same screen from step 9 disable Pocket Detection if you want Wireless AA to launch without removing yoour phone from your pocket.
  11. Phone - Connect to your OAP Hotspot called OpenAutoPro (default password: 1234567890) or the password you set in step 3.
  12. Phone - (Optional) Your phone may complain about the Hotspot not having internet access.  Make sure your phone is configured to use both WiFi & Cell Data at the same time.  On your phone go to Settings -> type Wi-Fi Preferences (depending on brand phone and Android version this may be called something different, you'll have to search) -> Enable "Intelligent network switch" (Samsung phones call this Smart network switch).
  13. Phone - (Optional) While on the same screen as step 12 disable "Intelligently select the best Wi-Fi" if you find your phone keeps disconnecting from the OAP Hotspot.
  14. Phone - (Optional) Disconnect from the OAP Bluetooth and then reconnect.  This should simulate your phone connecting to OAP after it boots up and Wireless AA should then launch.  If not I'd recommend restarting your OAP/RasPi and phone to get everything into a clean state.  The Bluetooth connection is only used to tell your phone it's connected to a AA capable system and will tell your phone to launch AA which will then auto switch to your OAP Hotspot and connect.
Written by an OAP newbie who spent two weekends trying to get this work. Despite the official documentation and other threads on how to do this, I have constantly failed to get it to work until recently. I documented the following which worked for me with lots of trial and error including notes on issues I've encountered and my solutions for those. I hope it can help others.

This was performed in OAP 7.0 on a Raspberry Pi 4 B with external USB Bluetooth, Soundcard and Microphone dongles (required).

Android Auto (AA) Phone Preparation
  1. Open AA Settings and scroll down to Version.

  2. Tap Version repeatedly until a pop up asks you to Enable Developer Mode -- tap option to allow.

  3. At the top right of this screen, tap the three dots and tap Developer Settings.

  4. Enable ‘Add Wireless Projection To Settings’ and then close AA.
OpenAutoPro (OAP) Preparation
  1. Flash OAP 7.0 to an SD Card and insert into Raspberry Pi (RPi).

  2. Connect all the required external USB devices to the RPi: Bluetooth, Soundcard, Microphone. Without these devices connected, Android Auto will not launch on OAP.

  3. Power up the RPi

  4. When OAP is booted, tap Settings then Wireless.

  5. Under Hotspot band, tap 5GHz (for best results if supported by both your RPi and Phone) and then tap the Hotspot button above to enable it. There will be a few seconds of what seems like input lag when tapping on these buttons, give it a moment to switch WiFi modes.

  6. Under Settings, tap AA, tap System and tap on Start Android Auto Automatically, then tap on Wireless Android Auto. I disabled Show Top Bar in Android Auto because it was annoying seeing another bar with Time, Battery, etc since AA already displays this.
Note: Enabling Hotspot on OAP will disable all existing WiFi connections previously established in Raspbian OS.

Raspbian OS (ROS) Preparation
  1. In OAP tap the Power Button Icon at the bottom of the screen and then tap Return to minimize OAP and display the ROS Desktop.

  2. (Optional): If this is your first time entering ROS, and are prompted, complete the initial setup. Do note that when you reach the WiFi Network screen at the end of the setup, no network will be displayed because you already enabled Hotspot in OAP. You can skip this step in the ROS setup process.

  3. At the top-right of the ROS desktop, click on the Bluetooth Icon and then Add Device.

  4. Pair your Phone with ROS. You may encounter an error when attempting to pair from the phone to ROS, but you may still be paired. Check the Bluetooth connections on the Phone and in ROS.

  5. On your Phone, connect to a new WiFi Network. Look for OpenAutoPro in the WiFi list and connect with the default password: 1234567890.

  6. For good measure, reboot your Phone and RPi.

  7. After reboot, test AA WiFi connection. You might need to enter an IP Address the first time (like I did) before it automatically connects. Under your OpenAutoPro Hotspot connection on your Phone, tap the connection and look for the IP address. You might need to click Edit the connection to see the variables under Advanced.
Notes on Issues & Solutions

The following are some issues I had to deal with that were not obvious or covered in the official OAP  documentation.
  1. Every change I’ve made in ROS or OAP required me to reboot the system to apply these changes. I suggest doing the same on your end to prevent headaches.

  2. Some of the ROS menus won’t display unless you use a mouse for right-click functions that enable sub menus for Bluetooth, WiFi and Sound.

  3. In ROS you might need to set the default Audio Input and Output device. Tap the ROS icon at the top-left, then tap Sound & Video -> PulseAudio Volume Control. Tap the Output Devices tab, then tap on the check mark for the audio adapter that is your external USB Soundcard. Same for the Input Devices tab. Reboot System.

  4. An external USB Microphone dongle is required for OAP to start up, however when using Bluetooth Audio on the Phone, or a device connected to the Phone for audio (such as your car), the USB Microphone dongle doesn’t appear to be used for voice, instead the microphone on the Bluetooth device seems to be used. I tested this with wireless headphones connected to my Phone, as well as the microphone built into my car connected to my phone via Bluetooth. However, OAP still requires an external USB Microphone dongle to function.

  5. Google Assistant (Ok Google / Hey Google) requires data to perform some functions. When using Hotspot on OAP, normal WiFi functions are disabled. With the Phone connected to the Hotspot on OAP, you have to rely on Cell Data for Hey Google. There may be some lag in between commands as Google Assistant accesses the internet. This is a known issue with Google that others are experiencing outside of OAP.

  6. There is a known issue in AA with Hey Google commands while music is playing, it will not always respond to you. When the music is paused, it will then respond to you. This also seems to be a random occurrence others experience outside of OAP.

  7. My first inclination on setting up a new OS is to modify network settings to match my network. This was a mistake to do with ROS out of the box. I made so many network changes that I was unable to get Hotspot working with OAP because I set the ROS network to match my IP Address block of 192.168.1.X instead of using the default one that OAP uses which is 192.168.4.X. This caused the OAP Hotspot connection on my phone to loop through “Obtaining IP Address” indefinitely. Once I reflashed OAP with its unmodified default settings, and only setup the Wireless Hotspot connection out of the box, it worked. The initial ROS setup confused me about having to setup a WiFi connection so I started modifying settings when it didn't work because Hotspot was on.

  8. For best Wireless performance, OAP needs to be the WiFi Hotspot. Your phone needs to be the Client that is connected to the Hotspot. I’ve seen instructions conflating both methods, and I tried both. When the Phone is the Hotspot, performance is really bad. You can also modify ROS to connect to your normal WiFi Network without Hotspot and enable the AA Head Unit Server on your Phone to connect to the same network, but the performance is also really bad -- plus you likely won’t be using this OAP head unit at home, but in your car.

  9. The AA Wired Connection works well with a USB Hub connected to the RPi. I’ve been able to connect some of the external USB Devices to a small USB Hub that is connected to the RPi without issues, including the phone itself connected to the hub which also charges while the RPi is on.

  10. For the best balance of Visual and Performance on my end, for both a Samsung Galaxy Note 8 and a Moto G7, in the OAP settings for AA -> Video, I have set the Resolution to 720p, FPS to 60 and DPI to 200. This gave me a nice crisp, clean, high res look with really good touch and drag performance both Wirelessly and Wired. In fact Wireless performance is almost as good as the wired, with just a few hiccups every so often.
USB Hardware I can confirm worked for me with these instructions:

USB Microphone:
USB Soundcard: (w/no Mic connected to Mic port).
USB Bluetooth: An unknown generic BT 4.0 brand I already had laying around for years.

Forum Jump:

Users browsing this thread: 1 Guest(s)