Not able to start Mirroring

User avatar
Chrisfromwa
Posts: 58
Joined: Wed Sep 19, 2018 2:21 pm

Not able to start Mirroring

Post by Chrisfromwa » Thu Mar 07, 2019 3:34 am

Hello,

I just updated OAP to the latest version, and wanted to try out the screen mirroring.
But I'm not able to get it to work.

I have a Galaxy S8 and I have enabled USB Developer
When I click the Screen Mirror button in the UI, the screen flickers for a second and then it just sits at the OAP home screen.

Is there another setting I need to enable?

BlueWave
Site Admin
Posts: 394
Joined: Tue Sep 18, 2018 6:30 am

Re: Not able to start Mirroring

Post by BlueWave » Thu Mar 07, 2019 6:29 am

Did the Raspberry PI detect your phone after hotplug? Is your phone indicating that debugging device is connected? It might be needed to enable MTP mode.

User avatar
Chrisfromwa
Posts: 58
Joined: Wed Sep 19, 2018 2:21 pm

Re: Not able to start Mirroring

Post by Chrisfromwa » Fri Mar 08, 2019 9:48 pm

I was able to get it working, looks like USB debugging got turned off again somehow.

Falchulk
Posts: 3
Joined: Mon Mar 04, 2019 10:30 pm

Re: Not able to start Mirroring

Post by Falchulk » Sat Mar 09, 2019 12:18 pm

Something I noted with my S9, I can go from mirroring to Android Auto with no problem. Going from Android Ayto to mirroring requires either restarting OpenAuto on the Pi, or disconnecting and reconnecting the USB to the phone. Just fyi.

User avatar
mrfusion92
Posts: 4
Joined: Sat Mar 02, 2019 9:00 am

Re: Not able to start Mirroring

Post by mrfusion92 » Sat Mar 09, 2019 2:02 pm

Falchulk wrote:
Sat Mar 09, 2019 12:18 pm
Something I noted with my S9, I can go from mirroring to Android Auto with no problem. Going from Android Ayto to mirroring requires either restarting OpenAuto on the Pi, or disconnecting and reconnecting the USB to the phone. Just fyi.
Yep, same for me

BlueWave
Site Admin
Posts: 394
Joined: Tue Sep 18, 2018 6:30 am

Re: Not able to start Mirroring

Post by BlueWave » Sun Mar 10, 2019 5:25 pm

Switching from AA to mirroring have some limitations caused by handling USB connectivity and AA overlay during the projection.
We suggest to access Android application directly from AA.

rpg100
Posts: 8
Joined: Sat Dec 15, 2018 6:34 pm

Re: Not able to start Mirroring

Post by rpg100 » Wed Mar 13, 2019 7:55 pm

I am in the same situation with an S8, but I do not understand the overcome proposed by bluewave . Can you explain It again, with other words?

Thanks

Rafael

BlueWave
Site Admin
Posts: 394
Joined: Tue Sep 18, 2018 6:30 am

Re: Not able to start Mirroring

Post by BlueWave » Sat Mar 16, 2019 1:47 pm

@rpg100 which situation: mirroring or switch from AA to OAP does not work ?

mikiano
Posts: 4
Joined: Mon Jan 21, 2019 9:07 am

Re: Not able to start Mirroring

Post by mikiano » Tue Mar 19, 2019 9:04 pm

Mirroring with Galaxy S7 worked for me, but only when Android Auto has not been started before. Once Android Auto has started, mirroring won't work anymore, even after terminating the Android Auto session.

So Autostart Android Auto needs to be switched off and Mirroring needs to start for it to work.

Also, I can't seem to get fullscreen mirroring. I am currently using the S7 with 1920x1080 and on an original Raspberry Pi 7" Touch Screen, 800x480. I have tried a series of resolutions through the settings (1920x1080, 1280x720, 800x480), but nothing seems to stretch it fully. The max I get is about 75% of the screen.

Any ideas?

mikiano
Posts: 4
Joined: Mon Jan 21, 2019 9:07 am

Re: Not able to start Mirroring

Post by mikiano » Tue Mar 19, 2019 9:32 pm

BTW: Maybe try RaspiCast too, this is effectively Chromecast for the Raspberry Pi. It's awesome, wireless fullscreen casting when you are using the same wireless network (eg the phone's hotspot).

Tutorial here: https://thepi.io/how-to-use-your-raspbe ... lternative

Notes:
- SSH should already be enabled
- OMXPlayer is already installed with the standard AndroidAuto Pro images
- You only need to add OMXViewer if you want to cast images
- I had to set Omxplayer command line options to --no-osd in RaspiCast Advanced Options. This is to make my Raspberry Pi 7" touchscreen configuration work. The screen only flashes if I don't.
Last edited by mikiano on Tue Mar 19, 2019 9:41 pm, edited 1 time in total.

Post Reply