No Audio

Post Reply
User avatar
Chrisfromwa
Posts: 61
Joined: Wed Sep 19, 2018 2:21 pm

No Audio

Post by Chrisfromwa » Sun Jan 13, 2019 4:58 pm

Hi,
So today I finally had some time to mess with my install, and when I got it hooked up. I noticed that I don't have any audio for some reason now.

I brought it back inside, and experience the same thing. It used to work, so not sure what is going on.

I have a HIFI Berry HAT.

The main OS volume is set to MAX, and the volume in OA is not at 0.

When I go into the sound settings of the OS, I do see an odd error that says

'Connection to Pulse Audio failed'
pulse audio2.PNG
pulse audio2.PNG (196.36 KiB) Viewed 487 times
Anyone know what I can troubleshoot to get this working again?
I'm using the most recent release of Open Auto.

User avatar
Chrisfromwa
Posts: 61
Joined: Wed Sep 19, 2018 2:21 pm

Re: No Audio

Post by Chrisfromwa » Sun Jan 13, 2019 10:03 pm

So a little update.

I tried reflashing the card, with a clean OpenAuto. Still no audio.
I then tried flashing the latest version of Crankshaft.
After I selected in the Crankshaft options to use the HIFI Berry, audio works OK. Is there a similar setting in OpenAuto, to select the HIFI Berry as the sound card?

Any ideas why it's not working in OpenAuto now? The only change I've made recently is updating to the latest version.

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: No Audio

Post by BlueWave » Sun Jan 13, 2019 10:43 pm

Nothing changed regarding audio in the latest release. Maybe after upgrade you missed some configuration that you did previously?

Please follow https://support.hifiberry.com/hc/en-us/ ... -or-higher instructions and double check that everything was configured properly.

CarlS
Posts: 22
Joined: Thu Nov 15, 2018 1:14 pm

Re: No Audio

Post by CarlS » Wed Jan 23, 2019 7:08 pm

Chirisfromwa did you get this fixed?
I had a similar issue with my IQaudio DAC plus.
After some googling I found several posts talking about similar issues with pulseaudio on stock raspbain. The only solution that seems to work is to delay starting of the pulse audio server or at least restarting it after its crashed at logon.

I'm hoping to get some time tonight to install the latest update and finish some more on my setup. So I'll check what the fix was. I do still get a disconnect between OA and the volume controls sometimes on first boot, but restarting OA usually sorts it out, without restarting the pi.

CarlS
Posts: 22
Joined: Thu Nov 15, 2018 1:14 pm

Re: No Audio

Post by CarlS » Thu Jan 24, 2019 2:35 am

I had to add the following two lines to /home/pi/.config/lxsession/LXDE-pi/autostart file.
rm -rf /home/pi/.config/pulse
@pulseaudio --start

The first line basically removes the whole pulseaudio config in the pi user directory.
The second line starts pulseaudio, the @ means it will be restarted if it crashes again.
Without these lines I have the same error every time I reboot. They can be ran from a terminal to test.

There are a couple of down sides to this, system boot time is longer and system volume will default to 100% on every boot.
I've also tried several other solutions from the web, but nothing else works.
This does not appear to be OA related and is the same on stock Raspbain for me!
Hope this helps, till a better fix is found.

CarlS
Posts: 22
Joined: Thu Nov 15, 2018 1:14 pm

Re: No Audio

Post by CarlS » Sun Jan 27, 2019 10:01 pm

Chrisfromwa wrote:
Sun Jan 13, 2019 10:03 pm
So a little update.

I tried reflashing the card, with a clean OpenAuto. Still no audio.
I then tried flashing the latest version of Crankshaft.
After I selected in the Crankshaft options to use the HIFI Berry, audio works OK. Is there a similar setting in OpenAuto, to select the HIFI Berry as the sound card?

Any ideas why it's not working in OpenAuto now? The only change I've made recently is updating to the latest version.
A bit if an update for you! I still haven't found a true fix for this, but I do have an improvement on what I suggested before.
Instead of removing the whole pulse config folder. Just remove the config file for the default-source at startup.
On my system the full file name is e2f7f9b303df4bd98f56edefd7d40c5a-default-source.

Add the following to /home/pi/.config/lxsession/LXDE-pi/autostart to remove it.

Code: Select all

rm -rf /home/pi/.config/pulse/*default-source
It doesn't seem to be necessary to tell pulseaudio to restart either, and this maintains the previous volume setting.
So far I've been fine tuning other things all day and restarted the system several times, and pulseaudio hasn't crashed.

Post Reply