Solution for black Screen after start of Android Auto

Here you can find information how to do some cool things with OpenAuto Pro
ipepe
Posts: 25
Joined: Wed Jan 23, 2019 7:44 am

Re: Solution for black Screen after start of Android Auto

Post by ipepe » Wed Jan 23, 2019 7:49 am

I'm also having black screen on AA. I'm not going to use sound output or input using AA. Also it was working on by USB cable on Crankshaft.
BlueWave wrote:
Mon Jan 07, 2019 10:10 pm
You can still use internal RPI sound card (disabled by default) with USB microphone or any DAC that supports microphone input.
How to enable internal RPI sound card? How can I make it work?

BlueWave
Site Admin
Posts: 522
Joined: Tue Sep 18, 2018 6:30 am

Re: Solution for black Screen after start of Android Auto

Post by BlueWave » Wed Jan 23, 2019 8:02 am

ipepe wrote:
Wed Jan 23, 2019 7:49 am
I'm also having black screen on AA. I'm not going to use sound output or input using AA. Also it was working on by USB cable on Crankshaft.
BlueWave wrote:
Mon Jan 07, 2019 10:10 pm
You can still use internal RPI sound card (disabled by default) with USB microphone or any DAC that supports microphone input.
How to enable internal RPI sound card? How can I make it work?
In order to re-enable internal sound card you must do:
1. edit sudo nano /etc/modprobe.d/raspi-blacklist.conf and comment (#) or remove blacklist snd_bcm2835
2. edit /boot/config.txt and (if exists) comment (#) or remove dtparam=audio=off

Please note that microphone input is mandatory (even if you do not use it) and OpenAuto Pro may not work as expected without it.

ipepe
Posts: 25
Joined: Wed Jan 23, 2019 7:44 am

Re: Solution for black Screen after start of Android Auto

Post by ipepe » Wed Jan 23, 2019 9:37 am

Noted. I guess that I need to plan how to mount microphone ;)

upptakari
Posts: 2
Joined: Thu Jan 24, 2019 6:09 pm

Re: Solution for black Screen after start of Android Auto

Post by upptakari » Thu Jan 24, 2019 6:26 pm

Hi

I´m using a justboom amp hat in my setup, it worked well with crankshaft but lack of volume control was a problem, had to unplug the phone to make changes to volume.

So i decided to get oap but was greeded with tha black screen.

If I use "sudo modprobe snd-dummy" I can get inn to open auto, but that disables my dac.

Is there any way to use open auto without usb mic ? My understanding is that rpi cant take two different external soundcards.

if I cant use my amp hat (works in rasbian) then I have no use for aop =(

how do you guys manage to use hifiberry with open auto pro?

cheers

BlueWave
Site Admin
Posts: 522
Joined: Tue Sep 18, 2018 6:30 am

Re: Solution for black Screen after start of Android Auto

Post by BlueWave » Fri Jan 25, 2019 9:13 pm

BlueWave wrote:
Mon Jan 07, 2019 10:10 pm
In order to run OpenAuto Pro properly you need the microphone input (for purposes of voice commands in Android Auto). External USB sound card is not needed but it is the easiest way to provide audio input and output by one device. You can still use internal RPI sound card (disabled by default) with USB microphone or any DAC that supports microphone input.

According to your question - you can use any USB sound card that is supported by Raspbian OS.
You can configure default output through your dac ( please refer to dac manufacturer user guide ) and default input to USB sound card/microphone.

One way or another, as described in system requirements, microphone is obligatory.

In open source version due to lack of microphone unexpected crash is very likely.

mtktm
Posts: 1
Joined: Tue May 07, 2019 7:23 pm

Re: Solution for black Screen after start of Android Auto

Post by mtktm » Wed May 08, 2019 9:20 pm

I just got the image loaded on an sd card that came with my pi, and am having the black screen issue when connecting my note 8.

I've already changed the video settings as listed in the instructions. Phone says android auto is running.
This is on the image that was sent to me yesterday. I believe version RC 3.3

I forgot to add this is on a pi 3B
And debug settings and relevant settings enabled

BlueWave
Site Admin
Posts: 522
Joined: Tue Sep 18, 2018 6:30 am

Re: Solution for black Screen after start of Android Auto

Post by BlueWave » Thu May 09, 2019 6:09 am

mtktm wrote:
Wed May 08, 2019 9:20 pm
I just got the image loaded on an sd card that came with my pi, and am having the black screen issue when connecting my note 8.

I've already changed the video settings as listed in the instructions. Phone says android auto is running.
This is on the image that was sent to me yesterday. I believe version RC 3.3

I forgot to add this is on a pi 3B
And debug settings and relevant settings enabled
What sound card and microphone are you using?

lazypug
Posts: 3
Joined: Fri May 17, 2019 1:19 am

Re: Solution for black Screen after start of Android Auto

Post by lazypug » Fri May 17, 2019 1:26 am

Currently experiencing black screen issue.

Sound Card:
https://www.amazon.com/gp/product/B01LH ... UTF8&psc=1

LCD/Touch (Set to 800X480):
https://www.amazon.com/gp/product/B013J ... UTF8&psc=1

Microphone/Speakers (only for testing):
https://www.amazon.com/Bose-QuietComfor ... ics&sr=1-3

Settings for Android Auto screen setting are set to 1080p. Using the non-pro version everything works great, I'm not sure what the problem is.

Please help.
Thank you,
LP

lazypug
Posts: 3
Joined: Fri May 17, 2019 1:19 am

Re: Solution for black Screen after start of Android Auto

Post by lazypug » Fri May 17, 2019 1:18 pm

I can also provide the log if needed.

BlueWave
Site Admin
Posts: 522
Joined: Tue Sep 18, 2018 6:30 am

Re: Solution for black Screen after start of Android Auto

Post by BlueWave » Fri May 17, 2019 1:38 pm

Please replicate the issue several times and send us logs at contact@bluewavestudio.io

Logs are located at /home/pi/.openauto/cache/openauto.log

In addition please send us your phone model, and detailed configuration.

Meantime please double check all connection, and re-flash the image to be sure that there are not any changes.

Post Reply