Release Candidate of OpenAuto Pro 3 available

Information and issues with beta version of OpenAuto Pro
BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Release Candidate of OpenAuto Pro 3 available

Post by BlueWave » Mon Dec 10, 2018 9:14 pm

We are ready with RC software. More info:

http://bluewavestudio.io/index.php/blog ... -available

fraisdos125
Posts: 9
Joined: Fri Nov 09, 2018 5:38 am

Re: Release Candidate of OpenAuto Pro 3 available

Post by fraisdos125 » Thu Dec 27, 2018 7:41 am

Hello,

Tried today the release candidate with iOS 12:
- AD2P: OK
- calls: OK
- contacts list: not available

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: Release Candidate of OpenAuto Pro 3 available

Post by BlueWave » Thu Dec 27, 2018 8:02 am

fraisdos125 wrote:
Thu Dec 27, 2018 7:41 am
Hello,

Tried today the release candidate with iOS 12:
- AD2P: OK
- calls: OK
- contacts list: not available
OpenAuto Pro uses Phonebook Access Profile (PBAP) to access contacts on the phone. Did grant proper permissions to let OpenAuto Pro access your contacts? According to the iOS behavior it will sync contacts stored in the internal phone's memory only.

fraisdos125
Posts: 9
Joined: Fri Nov 09, 2018 5:38 am

Re: Release Candidate of OpenAuto Pro 3 available

Post by fraisdos125 » Thu Dec 27, 2018 10:47 am

Access granted.
All contacts into iCloud. Maybe due to that.
Strange that in my car all contacts are imported. Probably uses a different protocol.

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: Release Candidate of OpenAuto Pro 3 available

Post by BlueWave » Fri Dec 28, 2018 3:02 pm

Could you please try to switch off and on your bluetooth after pairing with OpenAuto Pro? It looks like your iPhone device sends empty contacts list.

fraisdos125
Posts: 9
Joined: Fri Nov 09, 2018 5:38 am

Re: Release Candidate of OpenAuto Pro 3 available

Post by fraisdos125 » Sun Dec 30, 2018 6:55 am

No effect switching off and on the connection. The only thing I can do when connected is "refresh contacts"

I discover another issue: title of the song disappear after 3 second of playing. Music continues without trouble.

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: Release Candidate of OpenAuto Pro 3 available

Post by BlueWave » Mon Dec 31, 2018 8:32 am

We have managed to test it with iPhone 6S. As we mentioned before, after devices are paired, looks like iPhone send empty contact list. We turned off and on Bluetooth and reconnect with Rpi. Then contact list was available.
As to the A2DP, we observed the same. For know it is hard to say want is the reason but it looks like phone application issue ( probably with new protocol version ). If you google this issue you will see that it is more and more popular with iOS and Android.

fraisdos125
Posts: 9
Joined: Fri Nov 09, 2018 5:38 am

Re: Release Candidate of OpenAuto Pro 3 available

Post by fraisdos125 » Wed Jan 02, 2019 6:08 pm

Tested again. No luck for me. Either unconnected & connected Bluetooth from the iPhone or from the raspberry. I did this with open auto started and not shut down.
Will try with another iPhone i can do the test with a 6s as well

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: Release Candidate of OpenAuto Pro 3 available

Post by BlueWave » Wed Jan 02, 2019 8:33 pm

Here is how it works with iPhone:
https://www.youtube.com/watch?v=04x8xy-jgGo&t=1s

Hisma
Posts: 42
Joined: Wed Nov 28, 2018 9:38 pm

Re: Release Candidate of OpenAuto Pro 3 available

Post by Hisma » Wed Jan 02, 2019 8:57 pm

I have encountered what appears to be a design flaw (not necessarily a bug), and was hoping it could be addressed.

I have now transitioned to using wireless AA from USB. It works well most of the time, however, sometimes (and I think this is a problem with my phone, not openauto), when trying to connect to my phone's IP address from the openauto interface, it just hangs on "trying to connect". Because the problem is probably on my phone, the connection never establishes, and it hangs on "trying to connect" indefinitely until I physically reboot my pi. Whenever this happens, I have to restart the headunit server before my phone can connect again.

Is there some way you can program a connection timeout? That way, if there is some sort of problem establishing a wireless connection, whether it be due to a problem with the phone, or a problem with the pi, it will automatically time out after say, 30 seconds or so? It's happened to me several times now and it's a bit of a pain.

Thank you.

Locked