Problem play service 15

Open source project topics.
Post Reply
bruschetta85
Posts: 2
Joined: Fri Feb 15, 2019 1:53 am

Problem play service 15

Post by bruschetta85 » Fri Feb 15, 2019 2:02 am

I noticed that both openauto pro and crankshaft were updated for the disconnection problem every 5 seconds.
I wanted to ask if even normal openauto will be updated

BlueWave
Site Admin
Posts: 394
Joined: Tue Sep 18, 2018 6:30 am

Re: Problem play service 15

Post by BlueWave » Fri Feb 15, 2019 7:40 pm

In fact only the OpenAuto Pro provides complex solution for this.

Crankshaft is based on OpenAuto open source version which, as you pointed, crashes after some time. It means that all application which use open source version are not fixed. In Crankshaft case, the mange to provide, so called, 'hot fix'. It means that they have bypass issue, but this and some others are still there. For example try to use AA over WiFi.
So far nobody have requested fix in open source OpenAuto repository, even if source code is open and available for everyone.

Currently we are busy with updates and improvements for OpenAuto Pro, however we plan to work on this in the future. Sorry but no specific date for this.
Please also note that for the OpenAuto Pro you pay once for lifetime software with updates free of charge.

bruschetta85
Posts: 2
Joined: Fri Feb 15, 2019 1:53 am

Re: Problem play service 15

Post by bruschetta85 » Fri Mar 08, 2019 3:13 pm

thanks for the answer, I do not use open auto pro because I was developing my open source software that integrated kodi of the developer would go with the addition of openauto. but then this damn error has come and I am still, because I do not know how to correct it. since you have corrected the problem on the pro version you could tell me the cpp file which causes the error. on some sites I read that the resposnsabile is him AndroidAutoEntity.cpp
I would like to understand more about trying to create a fix on my own

BlueWave
Site Admin
Posts: 394
Joined: Tue Sep 18, 2018 6:30 am

Re: Problem play service 15

Post by BlueWave » Fri Mar 08, 2019 5:54 pm

The thing is that OpenAuto Pro is based on different, improved application core, and in case we would like to provide the real fix for open source version we have to spent some time on refactoring code. Currently this not in our focus.

As OpenAuto is open source, feel free to dig this issue deeper and create pull request on our git repository. We are happy to review those changes.

Post Reply