Adding apps

General discussions
jennmike2
Posts: 6
Joined: Mon Jan 21, 2019 1:15 am

Adding apps

Post by jennmike2 » Mon Jan 21, 2019 1:17 am

is there a way to add ex. google play music or youtube music? or other apps?

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: adding apps

Post by BlueWave » Mon Jan 21, 2019 7:18 am


Nosher
Posts: 9
Joined: Thu Mar 21, 2019 5:28 pm

Re: Adding apps

Post by Nosher » Fri Mar 22, 2019 10:30 am

I have added the OBD2 car diagnostics program - scantool, I have edited the openauto_applications.ini and see the icon on the applications screen, and set the path correctly but when I tap the icon it goes to the system desktop, please help

thank you

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: Adding apps

Post by BlueWave » Fri Mar 22, 2019 12:34 pm

Please post your config changes.

Nosher
Posts: 9
Joined: Thu Mar 21, 2019 5:28 pm

Re: Adding apps

Post by Nosher » Fri Mar 22, 2019 2:42 pm

[Applications]
Count=4



[Application_0]
Name=Kodi
Path=/usr/local/bin/kodi
IconPath=/home/pi/icons/icon_kodi.png
Arguments=
Autostart=false

[Application_1]
Name=Web browser
Path=/usr/bin/chromium-browser
IconPath=/home/pi/icons/icon_chrome.svg
Arguments=--start-maximized
Autostart=false

[Application_2]
Name=Radio
Path=/usr/local/bin/welle-io
IconPath=/home/pi/icons/icon_welleio.png
Arguments=--disable-splash
Autostart=false

[Application_3]
Name=OBD2
Path=/usr/local/bin/scantool
IconPath=/home/pi/icons/obd.png
Arguments=
Autostart=false

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: Adding apps

Post by BlueWave » Fri Mar 22, 2019 8:13 pm

Configuration looks good.

Is the provided path correct? Does the application runs if you start it directly from given location?

Nosher
Posts: 9
Joined: Thu Mar 21, 2019 5:28 pm

Re: Adding apps

Post by Nosher » Fri Mar 22, 2019 9:06 pm

yes it runs if I open terminal and type scantool

BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: Adding apps

Post by BlueWave » Fri Mar 22, 2019 11:51 pm

Could you please post a link to the application that you are trying to use? We would like to test it in our environment.

Nosher
Posts: 9
Joined: Thu Mar 21, 2019 5:28 pm

Re: Adding apps

Post by Nosher » Sat Mar 23, 2019 1:46 pm


BlueWave
Site Admin
Posts: 453
Joined: Tue Sep 18, 2018 6:30 am

Re: Adding apps

Post by BlueWave » Sat Mar 23, 2019 3:48 pm

We tested it and everything works fine.

Are you using any special version of the ScanTool? If you installed it via apt-get command then path to the executable should be /usr/bin/scantool.

Code: Select all

[Application_3]
Name=OBD2
Path=/usr/bin/scantool
IconPath=/home/pi/icons/obd.png
Arguments=
Autostart=false
Hint:
If you want to add some system executable as a shourtcut in OpenAuto Pro but you are not sure about absolute path, then execute which COMMAND, e.g. which scantool. That will print-out the absolute path of the command which you can use in openauto_applications.ini config.

Post Reply