Very laggy UI

juliusd
Posts: 8
Joined: Wed Oct 10, 2018 7:51 pm

Very laggy UI

Post by juliusd » Wed Oct 10, 2018 8:01 pm

Hello,
I have RPI B+, recently bought OpenAuto pro and enjoyed it for the most part except for very slow and stuttering animations and long response times in the main OpenAuto menu.

When starting OpenAuto from terminal I am getting warning:
"JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform."
Could this be the reason?

All I've installed was kuman touchscreen driver: https://github.com/goodtft/LCD-show
Also I'm running on 2A supply source but no low power warning.

User avatar
Chrisfromwa
Posts: 47
Joined: Wed Sep 19, 2018 2:21 pm

Re: Very laggy UI

Post by Chrisfromwa » Wed Oct 10, 2018 8:43 pm

Yes I've also noticed the lag between screens and the animations.
Hopefully this is something that can be improved on a future version.

BlueWave
Site Admin
Posts: 303
Joined: Tue Sep 18, 2018 6:30 am

Re: Very laggy UI

Post by BlueWave » Wed Oct 10, 2018 9:50 pm

Looks like installation scripts of your LCD use outdated desktop driver. Try to change it to Fake KMS by adding below lines to /boot/config.txt file

Code: Select all

gpu_mem=256
dtoverlay=vc4-fkms-v3d

juliusd
Posts: 8
Joined: Wed Oct 10, 2018 7:51 pm

Re: Very laggy UI

Post by juliusd » Thu Oct 11, 2018 5:15 pm

Setting in to fake kms helped alot. It is a joy to use.

Thank you.

erikh
Posts: 8
Joined: Tue Jan 08, 2019 9:07 pm

Re: Very laggy UI

Post by erikh » Fri Feb 01, 2019 5:11 pm

My /boot/config was already set according to this.

I still have an extremely laggy UI, though. Are there any other tricks?

BlueWave
Site Admin
Posts: 303
Joined: Tue Sep 18, 2018 6:30 am

Re: Very laggy UI

Post by BlueWave » Fri Feb 01, 2019 5:14 pm

Please post content of your config.txt file here.

erikh
Posts: 8
Joined: Tue Jan 08, 2019 9:07 pm

Re: Very laggy UI

Post by erikh » Fri Feb 01, 2019 5:31 pm

Code: Select all

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=off
#dtoverlay=vc4-kms-v3d
gpu_mem=256
dtoverlay=vc4-fkms-v3d
disable_splash=1
If I try the vc4-kms-v3d driver, I get no output at all, but after some googling that is a separate raspbian-related issue.

BlueWave
Site Admin
Posts: 303
Joined: Tue Sep 18, 2018 6:30 am

Re: Very laggy UI

Post by BlueWave » Fri Feb 01, 2019 6:13 pm

KMS driver forces HDMI output. What display do you use?

Please try to set driver and GPU memory using raspi-config tool. Also please check system load via htop tool.

erikh
Posts: 8
Joined: Tue Jan 08, 2019 9:07 pm

Re: Very laggy UI

Post by erikh » Fri Feb 01, 2019 6:17 pm

Ah, okay, that might be it!

I'm using the official rpi screen. What should the driver be set to, then?

But these are the settings that came with the openauto pro image that I got.

BlueWave
Site Admin
Posts: 303
Joined: Tue Sep 18, 2018 6:30 am

Re: Very laggy UI

Post by BlueWave » Fri Feb 01, 2019 6:38 pm

You should select the G2 GL (Fake KMS) driver. Also please remember to increase GPU memory to 256MB. Could you please also post load of your system (CPU usage and amount of allocated memory)?

Post Reply