Current version of the OpenAuto Pro is 12
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No A2DP
#1
Hi,

trying rc1 of beta 3 but can't get A2DP profile to work. HFP and Phonebook work.



Tried to set another class 200400 but no success. It always is reset to 780400.



Tried both internal and external bt adapter. Both only use HFP. Also disabled hcitool cmd in rc.local.



I also set class in /etc/bluetooth/main.conf to 200400 but still 78040 is set after reboot.



Phone is Note8 7.1.1



In OApro2.0 i set the bt by myself and it streamed music.
#2
In order to use A2DP you do not need to modify any config files. After pairing it should be plug and play. Did you grant the permissions on your phone to play music over bluetooth? What player (on the phone) do you use to play the music?
#3
No question to grand access for music. Just about phonebook access.



Also just a headset symbol on my phone. Changed class to 20043C which results in 78043C which should be ok but still just phonebook and callaccess
#4
tried to start pulseaudio daemon from commandline with sudo pulseaudio -D    - failed
pulseaudio -v reports an error:

E: [pulseaudio] module-echo-cancel.c: Can't cancel echo between a sink and its monitor
E: [pulseaudio] module.c: Failed to load module "module-echo-cancel" (argument: "aec_method=webrtc aec_args="analog_gain_control=0 digital_gain_control=0" source_name=echoCancel_source"): initialization failed.
E: [pulseaudio] main.c: Module load failed.

So i commented out everything from module-echo-cancel, reboot, repaired phone, and now it works...
#5
On your Android phone, in the settings of the paired Bluetooth devices (in that case OpenAuto-Pro device) you will have the switches with permissions for music playback, phone calls and contacts. If there is no music permission present it looks like A2DP service was not discovered during pairing. Are you sure that audio was configured properly (PulseAudio up and running, audio device connected) during pairing process? Did you add any modifications to the /etc/pulse/default.pa file?



Edit regarding echo cancel module:

Do you have any microphone input connected? It looks like pulse audio did not discover it.
#6
No, right now there is no mic connected. So the echo cancel module failes because of no mic input?
#7
Yes, echo cancel requires microphone input (echo source).
#8
you ever figure out a solution to this? i have a note 8 as well and my phone says its for handsfree calling too. wont play any music through a2dp or wont let android auto connect. screen just goes black when i plug in my phone. Thanks
#9
Sumtincoo Wrote:you ever figure out a solution to this? i have a note 8 as well and my phone says its for handsfree calling too. wont play any music through a2dp or wont let android auto connect. screen just goes black when i plug in my phone. Thanks

What sound card do you use? Please note that according to the system requirements from User Guide, the external sound card is required.
#10
I have a IQaudioIO Pi-DAC Pro soundcard


Forum Jump:


Users browsing this thread: 1 Guest(s)