Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't get audio to play over bluetooth
#1
I have tried everything I could see in the how to articles to get my Bluetooth audio out to work.



When I play something on Android auto I can see it playing in Pulse Audio because on the under Playback I see the level bouncing with the music however no sound is reaching my speakers. In the Output Devices Tab all I see is Dummy Output and its level is bouncing as well. The speaker icon on the Taskbar however shows the mute symbol and I'm not able to turn up the volume. I am using the internal Bluetooth module and the Bluetooth in openauto pro is set to local. Any thoughts?
Reply
#2
Regarding audio configuraion you can check this:

https://bluewavestudio.io/forum/viewtopic.php?f=24&t=14



For Bluetooth: please give us full details how did you setup your Bluetooth. We would like to reproduce it and then check what is going on.
Reply
#3
OK so what I did in order is as follows.

1. Boot up raspbian (first boot)

2. Did upgrades to raspbian

3. Turned on Bluetooth and paired to my speaker (tried 2 speakers)

4. Connected my speaker in right click audio menu

5. Went into open auto pro and set Bluetooth to local

6. it didn't work so I found this and followed instructions [url]https://bluewavestudio.io/forum/viewtopic.php?f=13&t=2[/url]

7. Rebooted and repeated pairing to speaker

8. Plugged phone back in and tried audio, no luck.

9. Went into pulse and saw the speaker level bouncing to music but can't get it to play. Also noticed the main volume control on Taskbar is muted and cannot be unmuted
Reply
#4
I forgot to say that I also tried this with the Bluetooth adapter setting at none by mistake but obviously had the same affect.
Reply
#5
I also tried turning Bluetooth off in the boot config and use a USB Bluetooth dongle and that rendered the same exact results
Reply
#6
We checked the issue yesterday on our reference devices. After few additional steps we were able to route audio through the paired bluetooth speakers.

1. Please install additional package needed for handling bluetooth via Pulse Audio

Code:
sudo apt-get install pulseaudio-module-bluetooth

2. Edit /etc/bluetooth/main.conf file

Code:
MultiProfile = multiple

3. It would be good to restart the RPI

4. Pair your bluetooth audio device with Raspberry PI 3 and select it via right click on the tray's speaker

5. Open PulseAudio Voule Control tool (via Start menu) and select A2DP profile of your bluetooth audio device at Configuration Tab

Also it might be necessary to set bluetooth sink as a default audio sink. It can be either done via command line or configuration file.
Reply
#7
I don't understand the sink part, can you walk me through that?
Reply
#8
OK so that works but it's very slow audio like slow mo and it sounds terrible quality wise. I don't know what logging would help. Thank you!
Reply
#9
Most probably you did not switch to A2DP profile but still using HFP to playback the music.

Try to force disable it by editing /etc/bluetooth/main.conf and add

Code:
Disable=Headset
 in General section.
Reply
#10
I actually had already done that and it was using a2dp
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)