Current version of the OpenAuto Pro is 12
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Solution for caller echo.
#1
When I am trying to make calls using OpenAuto Pro HFP (my android auto is always connected), callers are listening to their own sound back just after they speak. What might be the issue for that?

My setup:
RPi 3B+ with OpenAuto Pro 11
Orico Sound card: https://www.scorptec.com.au/product/head...340-sc2-bk
Generic Mic: https://bit.ly/3eQRTSt
BT Dongle: https://amzn.to/2Uh18lz

I am not quite sure what is the failing bit here? Do I need to change the mic, or soundcard or BT dongle to solve this issue? Also, there is a very low gain on the mic as I have to literally scream inside to talk to the person at another side, that might be due to the sound card or the mic itself. Too many possibilities. Has anyone been into the same boat?

Thanks in advance, help is highly appreciated.
Cheers! Tongue
Reply
#2
Same issue here, also echo issue for the one I am calling with.
Bought a Startech 7.1 usb sound card. Same issue.

Used 2 different microphones (one amplificed - one unamplified) same issue. (Also using RPI)

I think or OpenAuto or Raspbian must do the smart stuff with Echo cancellation, checked all settings within OpenAuto but it seems there are no settings related to this. Or there must exist

Hope anyone have idea's!?

Regards & Thanks
Reply
#3
(11-19-2020, 08:06 PM)hdservices Wrote: Same issue here, also echo issue for the one I am calling with.
Bought a Startech 7.1 usb sound card. Same issue.

Used 2 different microphones (one amplificed - one unamplified) same issue. (Also using RPI)

I think or OpenAuto or Raspbian must do the smart stuff with Echo cancellation, checked all settings within OpenAuto but it seems there are no settings related to this. Or there must exist

Hope anyone have idea's!?

Regards & Thanks

Please post more details about your setup.
Reply
#4
For sure;

Raspberry PI 4
OpenAuto 11
Startech 7.1 USB Soundcard (https://www.startech.com/nl-nl/kaarten-p...usbaudio7d)
2 different mic's tested, amplified and unamplified. Both have the same issue.

Any more info needed?

I am ok buying different devices/which should work better or is atleast tested by others where it is ok?

Regards Marco
Reply
#5
In /home/pi/.config/pulse/default.pa file please find below line

aec_args="analog_gain_control=0 digital_gain_control=0"

change it to

aec_args="analog_gain_control=0 digital_gain_control=0 mobile=1"

and check if there is any difference. 7.1 sound cards need huge computing resources to perform echo cancellation effectively. It may introduce some delay between processed and captured audio and result it echo.
Reply
#6
Hi BlueWave,

To be clear: The Startech USB 7.1 sound card is just new, before I had a simpler sound card, with same problem. Actually I bought specially the Startech, to hope the echo was fixed that way.

Thank you for the quick responses. Ofcourse I made time to test right away;

The setting mentioned is changed, but did not help yet.
I did do some further investigation; (Because you said there could be a delay and that's the probable cause)

I started a Youtube movie on my phone, there I see in the video someone talk, the sound goes through speakers of the car and there is a "big" delay. with the moving mouth on the video and the audio. So that indicates there is a delay.
I use Android Auto Wireless!

So I tested watching the Youtube with the USB Cable attached to the phone. There is a minimum delay (alot less)
Also tested a call with the cable, that's much better, there is still a very low echo (far away and not annoying as the caller says)

So the conclusion is, the system has the most (and the annoying part/delay) with Android Auto Wireless.
Do you have more tips on this one? Because I'd really like AA Wireless because of not using any cable ;-)

Regards Marco
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)