Current version of the OpenAuto Pro is 13
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Android Auto black screen
#1
Hello all,
 
I had previously been using OAP with my current setup and Android Auto worked fine (with the exception of google assistant - suspected microphone issue).

I recently ran the update script to upgrade from version 7.0 to the current version 11 and am now encountering the known issue of a black screen when starting android auto. This occurs with both cable connection and wireless.
 
Everything seems ok, mobile phone shows "connected to the car", but openauto pro shows a black screen with the top bar visible.

I have enabled "up to 1080p" in AA developer settings, as well as enabled wireless connection.
 
I've searched high and low in the forum but have found no solutions that worked for me.
 
I'm sure I'm compliant with system requirements since it was all working previously, but here is my list of hardware:
• Raspberry PI 3B, 3B+ or 4B  -> 4B, 4gb RAM
• 8GB SD card -> 32 GB
• Touchscreen -> 7" IPS Touch Screen 1024x600
• 5V 3A power supply -> Official raspberry pi 3A power supply, and Aukru powered usb hub
• External sound card with microphone input -> Techrise USB external sound card audio adapter from amazon
• External Bluetooth adapter -> GSM universe mini USB bluetooth key from amazon
 
My phone is a Samsung Galaxy S9 running Android 10.
 
I am also encountering a new issue with my bluetooth connection. When I connect to the Pi, OAP is only available for calls and contact access on my phone. Audio is not an option (it was before I updated). I have tried unpairing the device, repairing etc but this doesn't fix it.
 
Is there anything I can try to solve these issues?
 
Any help would be very much appreciated.
 
Thanks,
 
Dan
#2
Did you try to re-flash the image?
#3
I didn't, just ran the update script. I've now re-flashed the new image and it solved both my issues. Thanks!


Forum Jump:


Users browsing this thread: 1 Guest(s)