Current version of the OpenAuto Pro is 11
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OAP11 can't restart after exit to Raspbian desktop
#1
SOLVED.

I just updated to OAP11. Tried using the update script, but since I was starting at OAP7 it failed. I re-flashed the sd card and reinstalled. Everything seems to work, but when I exit to the Raspbian desktop to do other things, when I click on the openauto shortcut on the desktop it locks up the computer...every time....and I have to unplug power to restart. I have also tried unsuccessfully to restart OAP from the command line. I can use the OAP "return" function, where OAP remains running but minimized, but cannot exit it, then restart it from Raspbian.

raspberrypi 4b 2G
soundcard: audioinjector zero (with mic)
3A power source
7" Official Rpi touchscreen (powered separately)
Navit installed and running
64G PNY Elite sd

Tony
Reply
#2
Is the navit running in the background? Looks like performance issue. How it behaves on clean installation without your additional changes?
Reply
#3
(10-12-2020, 11:54 AM)Daniel_BlueWave Wrote: Is the navit running in the background? Looks like performance issue. How it behaves on clean installation without your additional changes?

It runs in the background when I use the OAP "return" function, just minimized on the Raspbian desktop. When I use the OAP "exit" function OAP cannot be restarted. Any attempt locks up the computer.

I will try it with a fresh installation of OAP11 without any changes and report back.
Reply
#4
OK. Here's the problem.

After flashing a new sd card, I installed OAP11. I exited to the Raspbian desktop to do the setup, password, etc, and did the update/upgrade to the current Raspbian.  After that OAP restarted without issue.

Then before installing any other software, I did rpi-update, which updates the firmware from 5.4 to 5.4.7. After rpi-update, OAP would no longer re-start and any attempt to do so would lock up the computer.

The installation script for the audio Injector Zero soundcard performs rpi-update during installation, which is why I tried that before installing any other software or apps.

This should be easily repeatable.
Reply
#5
Please note that firmware installed via rpi-update command is always in experimental/unstable state. There is a warning about thar before update process. We test OpenAuto Pro only with stable version of firmware/kernel. What exactly do you need from 5.4.7 kernel?
Reply
#6
The install script for the Audio Injector Zero sound card invokes rpi-update. I don't know why. I'll see if I can install it manually without rpi-update and see if it works.

I have been considering moving to a HiFiberry sound card anyway. Maybe it's time.

I just found ctrl-alt-D unlocks the system, so it must be something running in the background trying to re-start AOP.

Going to attempt to roll back to the former kernel.

and see if that doesn't fix things.

I rolled back to kernel 5.4.58, committed Aug 14 (before the release of OAP11) and it seems to have fixed the issue. I just verified that my AudioInjector sound card and Navit are still working. All is well again.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)