Current version of the OpenAuto Pro is 11
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to select language at first-install
#1
Greetings to all!

If this question is answered elsewhere, please accept my apology and please (if you're able) send me a link to that answer?

Problem: 
No keyboard response and limited mouse response at first-run language menu.

** Before details, Daniel from Bluewave sent me the link below, which (in short) indicates that I need to run this command: "sudo bwscursor show"

*** However (and I am new to RPi so sorry if this is a noob question) since I have the OAP language menu on my screen, I can't get to the console from the Raspian desktop's console.
Also, I searched for the RPi's IP address on my home network, and it does not show up - and I don't know how the OAP's instance of Raspian is configured. 

Hardware:
RPi 4B (4GB)
Connected via USB:
     Dell mouse (generic0
     Dell keyboard (SK3205-has smartcard reader) but has worked with Raspian w/o issue
Connected via microSD: 
     Samsung 256 GB card, freshly imaged (using Etcher) with this .img:
          bluewavestudio-openauto-pro-release-11.0.img

Issue:
After flashing my msdcard with the latest OAP .img file:
     RPi 4B boots successfully into OAP
     Language menu is displayed
     The only mouse response I get is when moving the scroll-wheel up and down:
          The menu does scroll, but the selected language stays on Cestina.
     I get absolutely no visible response using my keyboard.
          I WILL try a non-smartcard keyboard, but I don't have one usable at the moment
          This exact same keyboard works without error on the most current .iso for Raspian.

Please help if able and thank you in advance! Smile
Reply
#2
Hello,
Please have a look at https://bluewavestudio.io/community/show...p?tid=2048 . Use 1 and 2 key strokes to scroll through elements of the list.
Reply
#3
Thank you very much - and I already saw that and tried then when the link to that other answer was posted.

NONE of my keyboard keys do anything (at least not visible to me on my screen).

Could it be that those keyboard commands only work AFTER OAP has been installed?
...or maybe only after OAP has been configured?  Without knowing the language to use, how can OAP know which keyboard layout to use?

** Anyway, I am aware the my keyboard is NOT a generic usb keyboard and that the fact that it has a smartcard reader may be confusing OAP.

*** Unless there is a way to terminal into this "freshly-flashed," brand new OAP\RPi instance remotely, I'll have to try to use a "standard" normal keyboard.

**** Is the Raspian instance OAP used set up with already able to be connected to over my network?  If so, does it still have the generic username and password: pi\raspberry?

NEVER MIND! Smile
Your guidance was spot-on!

I had been switching keyboards around so much that I had not plugged my original keyboard back in!

Once I did, the "1" and "2" keys worked perfectly!

Thank you VERY much!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)