Current version of the OpenAuto Pro is 11
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Android Auto Connects but touchscreen is rendered useless
#1
Hi I just recently got the software and I got it installed successfully and can connect my phone to the raspberry pi and I can get android auto to launch however I don't have the ability to control any of the features in android auto except to go back out to main menu of openauto pro software

My Specs:
Raspberry PI 3 (I know the recommended is a Raspberry PI 4 2gb but this is what I had and thought I could make it work)
Storage 16gb
External usb sound card 
External bluetooth adapter (ZexMTE)
A usb C cable for my phone
Phone used is a One Plus 7t.

I would like to try to get the application to work with the raspberry pi 3 first but if I can't get it to work with the 3 I will buy a 4. Please help me solve this for this device and only suggest an upgrade if that is the last option.
       
Reply
#2
What screen are you using? Does it work well in OpenAuto Pro (not Android Auto) user interface?
Reply
#3
(09-16-2020, 05:14 AM)Daniel_BlueWave Wrote: What screen are you using? Does it work well in OpenAuto Pro (not Android Auto) user interface?
I am using the screen kuman 5 inch Resistive Touch Screen with the rest of the interface it works fine with no issues and can display everything properly.



Link for the screen:
https://www.amazon.com/gp/product/B07L9XM11M/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1 
Reply
#4
What happens when you change max_framebuffers=2 to max_framebuffers=1 (all occurrences) in /boot/config.txt file?
Reply
#5
(09-16-2020, 08:05 PM)BlueWave Wrote: What happens when you change max_framebuffers=2 to max_framebuffers=1 (all occurrences) in /boot/config.txt file?
After changing the buffer to 1 I can only access the dropdown for the volume and brightness I can't access anything else on the screen when android auto is launched but when I disconnect the phone from the raspberry pi I can access everything else just not when it was connected through android auto
Reply
#6
Is "Use touchscreen in Android Auto" option enabled in Settings -> Android Auto -> System?

Edit:
Does your screen support multitouch? Please change screen type from multi to single touch in Settings -> System and do the retest
Reply
#7
(09-16-2020, 10:48 PM)BlueWave Wrote: Is "Use touchscreen in Android Auto" option enabled in Settings -> Android Auto -> System?

Edit:
Does your screen support multitouch? Please change screen type from multi to single touch in Settings -> System and do the retest
It is resistive touch and it is single touch. I got it to work but barely I will try a different screen with the raspberry pi any suggestions?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)