Current version of the OpenAuto Pro is 11
Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issue with RetroPie when launched from OpenAuto applications
#11
(10-09-2020, 04:47 PM)Justindu Wrote:
(10-09-2020, 04:28 PM)al3k Wrote: hmm i tried again from scratch still no go.
Im on latest openauto pro version.

imake this file File:
/home/pi/emulationstation.sh

insert this content with my own paths from echo $PATH

#!/bin/bash
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games



I did chmod +x the file.

i edited openauto_applications.ini and put this content:

[Application_0]
Name=RetroPie
Path=/usr/bin/lxterminal
IconPath=/home/pi/.openauto/icons/icon_retropie.png
Arguments=-e ./emulationstation.sh --hold
Autostart=false

if i test to launch the script ./emulationstation.sh from terminal on the pi i get this error:

Oct 09 18:24:26 lvl0: Error creating SDL window!
Could not get EGL display
Oct 09 18:24:26 lvl0: Renderer failed to initialize!
Oct 09 18:24:26 lvl0: Window failed to initialize!


if I from the same terminal while at desktop enter this to terminal
ssh pi@192.168.4.1
enter passwd
and just write emulationstation
it launches retropie with no issues playing games, and I can quit the software and return to openauto.

I dont understand what the different running level while using ssh or just the terminal, same user, same commands, same desktop.
Is ssh in a deeper terminal level?

I did a RetroPie install on OAP 11.0, but in that case I did run the OS upgrade and install commands first.  It seemed not much was updated.  When you open a terminal from the desktop are you logged in as pi user - the same user you are logging in as via ssh?

Is the echo $PATH result the same comparing the ssh login results to the results from the desktop?

I don't have the same failures you are seeing launching the .sh script from command line.  Maybe google the errors and see what you get.
yes I use same user, and I get same PATH if I test locally on my pi and externally through ssh.
I did os upgrade and then I installed retropie, im running Raspberry Pi 3B+.
Reply
#12
Did you install RetroPie/-Arch like this?

https://bluewavestudio.io/community/show...p?tid=1090

This guide always worked although it's a bit old.
Reply
#13
(10-12-2020, 08:48 PM)marcb4 Wrote: Did you install RetroPie/-Arch like this?

https://bluewavestudio.io/community/show...p?tid=1090

This guide always worked although it's a bit old.

I used the RetroPie documented "manual" installation method - which is OS specific. I used the git method to download the setup scripts, 

git clone --depth=1 https://github.com/RetroPie/RetroPie-Setup.git

and then executed the installation

Here is their documentation:
https://retropie.org.uk/docs/Manual-Installation/
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)