Current version of the OpenAuto Pro is 9.0
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Android auto not aligned with screen when a second screen is connected
#1
Hi,

When I connect a second 1920x1080 screen on hdmi 0, along with de default 7" touch screen on DSI, OAP works well after I recalibrated the touch screen, but Android auto doesn't align to the screen, when I boot without the second screen everything is ok.

See videos.

https://youtu.be/e7ExhBBZnMI

https://youtu.be/Fhw11YK8pdI

Any help troubleshooting this ?
Reply
#2
(06-29-2020, 01:30 PM)Alexplose Wrote: Hi,

When I connect a second 1920x1080 screen on hdmi 0, along with de default 7" touch screen on DSI, OAP works well after I recalibrated the touch screen, but Android auto doesn't align to the screen, when I boot without the second screen everything is ok.

See videos.

https://youtu.be/e7ExhBBZnMI

https://youtu.be/Fhw11YK8pdI

Any help troubleshooting this ?


I've got a dual screen setup too that I'm long away from actually getting in the vehicle. I'll see if I can replicate the issues.

GFunkbus76
 - Working on dual screen setup to run 1976 bus AV and dash... eventually.
 - Work in long-term progress lol

YouTube Channel for some related videos
Reply
#3
(06-29-2020, 05:20 PM)GFunkbus76 Wrote:
(06-29-2020, 01:30 PM)Alexplose Wrote: Hi,

When I connect a second 1920x1080 screen on hdmi 0, along with de default 7" touch screen on DSI, OAP works well after I recalibrated the touch screen, but Android auto doesn't align to the screen, when I boot without the second screen everything is ok.

See videos.

https://youtu.be/e7ExhBBZnMI

https://youtu.be/Fhw11YK8pdI

Any help troubleshooting this ?


I've got a dual screen setup too that I'm long away from actually getting in the vehicle. I'll see if I can replicate the issues.


Also I noticed that only the display is shifted on the right, the touch coordinates are where they should be.
Reply
#4
I got it working.

You have to change the Android Auto system settings inside OAP, disable the show top bar option.
Reply
#5
(06-30-2020, 12:17 PM)Alexplose Wrote: I got it working.

You have to change the Android Auto system settings inside OAP, disable the show top bar option.


Nice find, It helps me with my issue as well.
Reply
#6
(06-30-2020, 02:20 PM)ozeraser Wrote:
(06-30-2020, 12:17 PM)Alexplose Wrote: I got it working.

You have to change the Android Auto system settings inside OAP, disable the show top bar option.


Nice find, It helps me with my issue as well.

What was you issue ? 
Maybe this could be some tweaking in OAP code to make it working anyway ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)