Current version of the OpenAuto Pro is 9.0
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Volume control partially displaying
#1
ello,
I mentioned this issue in this thread
https://bluewavestudio.io/community/showthread.php?tid=1678&action=lastpost

But thought I would start a new one,  so I wouldn't hijack it.

These issues happen randomly,  and doesn't seem to happen right at bootup.  I seem to notice it after driving awhile.

1st issue:
The volume control will get kind of stuck.  Where it will appear even when it's supposed to be collapsed. 
This has happened all the way back since using at least OAP 3 (maybe even earlier)

You can see in this picture what I'm talking about.   I can press the area,  and the control will fully display.  but when I click out.  It only goes up as much as you see.   Everything in AA works as expected,  I can press anyone there,  and everything will work.

Feature Request:
As you can see,  I don't have any physical controls for volume.  So I use the onscreen ones a lot.  Seeing how this bug allows both the volume and AA to appear at the same time.  It would be a great feature,  if it was possible for something a user can select to 'always show volume'  and at the bottom/top/side  a volume slider would appear.  Allowing easy access to change the volume,  with less eyes off the road.

I find myself driving with the volume down mostly,  because otherwise whenever I'm driving I would have to do 2 clicks to get to the volume.  1. on the dropdown,  and then on the slider.   So pretty much everything in AA is covered by the volume control black area.
[see attached picture]

2.  Another issue I've seen a few times,  is where the slider gets stuck.   I can drag my fingers or press the - or +  and the volume changes.  But the slider itself doesn't move.  Made a short video:

https://www.youtube.com/watch?v=7L2c5guLeSk

These issues have been happening on/off for the past couple years?  I'm noticing it more now,  that I finally have the system installed in the car.   It happens when AA is in Widescreen mode,  and also when in standard mode.

I've tried reflashing several times over the past few months when upgrading from prior versions.

PI 3B+
Wavesharescreen
USB MIC
USB BT
   
Reply
#2
Could you please post content of the /boot/config.txt? Looks like an issue with the GPU or its driver.

What is the exact model of your screen? After Raspberry PI foundation's update to the DKMS GPU driver, some waveshare screens became incompatible with Raspberry PI - they require to use legacy GPU driver that may lead to similar issues.
Reply
#3
This is the screen I have
https://www.amazon.com/gp/product/B01J5QPCVG/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

According to the FAQ, it says it's driver free not sure if that matters?

I'll try and pull the log off my PI as soon as I can.

It only happens randomly, I can go on one trip with no issue at all. The next time, the issue could pop up right away or 30 minutes into the drive. Only happens when using Android Auto. Everything in OAP seems to be working as expected.
Reply
#4
Here is my config.txt

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=off
dtoverlay=pi3-disable-bt
disable_splash=1

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
gpu_mem=256

#waveshare
max_usb_current=1
hdmi_group=2
hdmi_mode=87
hdmi_cvt 800 480 60 6 0 0 0
hdmi_drive=1
Reply
#5
Did you see anything in the config?
I'm hoping to drive the car this weekend if the weather is nice, let me know if there is anything else I can test or provide.
Reply
#6
We tried to reproduce the issue with all the screens and phones we have. Unfortunately it was not reproducible even once. According to the video, it looks like your phone did not release the focus after top bar expansion. Could you please try to reproduce the behavior and provide us /home/pi/.openauto/cache/openauto.log file? Also please try to reinstall Android Auto application or try to test with different phone.
Reply
#7
I've been trying to reproduce it when the car is sitting in the driveway, so far no luck.
Always seems to happen when I'm away and can't get to the log file.

Once it does, and I capture the log. I'll post it here.
Reply
#8
is your taskbar in raspbian set to auto hide? or have you changed it from the top position as this is when I've seen this issue on mine
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)