Current version of the OpenAuto Pro is 8.0
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Raspotify Compatibility
#1
Hello everyone,
I was wondering if anyone has managed to get Raspotify working with version 7 installed. I, unfortunately, have not been able to do so on my Rasp Pi 4 while using the OpenAuto Pro image but have been able to with the stock Raspian image. I'm assuming the issue lies with a modification that has been made in the OpenAuto Pro image since the audio cards that are present when running aplay -l are different compared to those when running stock Raspian. Any help or suggestions are greatly appreciated!

Thanks.

Update: After following the instructions I found here to reenable the onboard audio card I can now get audio to play through the built-in 3.5 jack but not the usb card.
Update2: It appears this issue stems from a pulseaudio process not allowing alsa to access the card because when I kill the pulseaudio process listed from running lsof /dev/snd/* audio from raspotify starts working immediately.
Reply
#2
For those interested, I solved my problem by reenabling the onboard sound card by following the instructions under the "How-To" section. I am now able to use Raspotify and OAP at the same time by using the rp's audio jack for output and my usb audio card's mic in for input.
Reply
#3
Thank you for the update and providing solution for your issue. We appreciate it.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)