Current version of the OpenAuto Pro is 8.0
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Path issues with google text to speech
#1
I built a small voice assistant that I loaded onto the pi.  Originally it was using espeak and it was fine.  It also worked ok before the 7.1 update, however now I'm running into an issue.

If I run the script from the terminal within raspbian, it works fine.  However, when running from the external applications menu within OAP, it is having some issues.  Namely it is skipping over portions of the code relating to the google cloud text to speech engine.

I haven't taken the time to have OAP run it with a terminal to see what's going on, but was hoping to see if there's arguments that would work to make it run out of that directory like it does in terminal.
Reply
#2
It would be really helpful with the investigation if you could provide mentioned command to run your application.
Reply
#3
(05-21-2020, 06:01 PM)BlueWave Wrote: It would be really helpful with the investigation if you could provide mentioned command to run your application.

It's just a bash code that restarts a python code out of a folder in the home directory.  

I guess the easiest thing to help me out is to know what directory the external applications runs out of.  If I put it in the same folder that might fix my issue.
Reply
#4
(05-22-2020, 12:12 PM)jvteam Wrote:
(05-21-2020, 06:01 PM)BlueWave Wrote: It would be really helpful with the investigation if you could provide mentioned command to run your application.

It's just a bash code that restarts a python code out of a folder in the home directory.  

I guess the easiest thing to help me out is to know what directory the external applications runs out of.  If I put it in the same folder that might fix my issue.

CWD is inherited from parent process. That is standard Linux behavior. By default it is home directory.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)