Current version of the OpenAuto Pro is 8.0
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
AA screen rotated (Cont)
#11
(03-15-2020, 05:11 AM)ozeraser Wrote: Ok so the raspberry Pi4/3 doesn't support 90Degree rotation when using the VC4 FKMS V3D driver, even though it works and is an option when using the Screen configuration utility.

The Openauto interface appears to honour the set rotation, but the AA doesn't. I'm no AA api expert, i do not know the api calls to AA, but surely we could just have a setting to tell it the rotation and dimensions. So the OMXplayer would still play in the incorrect rotation, however the AA is streaming in the correct rotation/size that we could set?

There is no way to set rotation for the Android Auto projection. The only parameters are DPI, overscan and resolution. However we will see if there is any possibility for a workaround on the Pi side.
Reply
#12
Gday again,

Just wondering if you have had a chance to look at this? the OMXplayer seems to support an --orientation 90 option (at least when playing an mkv)

* I had to get latest firmware, and i realise OMXplayer may be different than the OAP gui, just some thoughts.

-M
Reply
#13
Could you please check the behavior with the latest version of OpenAuto Pro?
Reply
#14
(05-20-2020, 02:03 PM)BlueWave Wrote: Could you please check the behavior with the latest version of OpenAuto Pro?


Yeah I'm running on OAP 8.0 at the moment.

The OAP application displays correctly, the touch works correctly, the AA stream is still portrait and not landscape, but the touch translation is operating correctly (in landscape). This may be confusing so i took a video;


https://www.youtube.com/watch?v=yhetsy_7riw
Reply
#15
Could you please connect your phone to Android Auto and grab the log file located at /home/pi/.openauto/cache/openauto.log?

Did you try to follow this post https://bluewavestudio.io/community/showthread.php?tid=1632&pid=9866#pid9866 ? Looks like screen rotation works properly in that case.
Reply
#16
(05-21-2020, 06:45 AM)BlueWave Wrote: Could you please connect your phone to Android Auto and grab the log file located at /home/pi/.openauto/cache/openauto.log?

Did you try to follow this post https://bluewavestudio.io/community/showthread.php?tid=1632&pid=9866#pid9866 ? Looks like screen rotation works properly in that case.

So I think we went through this hdmi_rotate originally. This apparently only works now with the legacy driver (https://www.raspberrypi.org/documentatio...otation.md), I tried display_hdmi_rotate and hdmi_rotate neither do anything with any value from 0,1,2,3 .

I have confirmed this previously is an issue with any HDMI monitor and OAP/AA stream, I have tested again with both small display and standard Samsungng tv, with photos included. The AA stream resolution changes correctly, but rotation isn't applied.


I have attached photos of the output from the raspberry pi with the rotation showing over the OAP interface, and the android auto showing it is ignoring rotation. These images are for both the Portrait display as well as a standard 1080p hdmi monitor.

I have also attached the log output from the portrait display showing each time i rotated the screen (Reboots make no difference to this behaviour)


Attached Files Thumbnail(s)
   

.txt   openautolog.txt (Size: 66.07 KB / Downloads: 1)
Reply
#17
From provided logs it looks like rotated screen dimensions are set after some time. Desktop starts with the 1080x1920 resolution but after few seconds it switches to 1920x1080. However, Android Auto projection has been started before the switch to 1920x1080. Do you use autostart of Android Auto? What happens when you connect the phone with some delay after start of the OpenAuto Pro?
Reply
#18
In the logs i was setting the rotation and then testing Android Auto projection, OAP was running the entire time. (restarting between rotation configuration doesn't change behaviour)

Time has no effect on this, 30 seconds or 30 minutes the projection isn't rotated, the resolution appears to work correctly.

Are you not able to reproduce this issue?

To reproduce;
Connect Pi4 to any HDMI screen
On the Pi4, Open Screen Configuration Utility from the desktop Preferences menu. Change it from default. Launch Android Auto projection, it will be in the correct resolution but in the default orientation/rotation.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)