Current version of the OpenAuto Pro is 10
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OAP 6.1 volume slider disabled [SOLVED]
#1
Just installed 6.1 ... first issue is that I can't remember what I did to get the volume slider working in previous releases.  Amixer says "DSP Program" is the mixer.  That's not what I expected to see.  Otherwise I have full volume through HifiBerry AMP2 HAT and no way to turn it down.
Reply
#2
(02-13-2020, 10:27 PM)Frank Wrote: Just installed 6.1 ... first issue is that I can't remember what I did to get the volume slider working in previous releases.  Amixer says "DSP Program" is the mixer.  That's not what I expected to see.  Otherwise I have full volume through HifiBerry AMP2 HAT and no way to turn it down.
Run the following command and paste the output..

Code:
pi@raspberrypi:~ $ amixer scontrols


You will then likely need to set MixerName= to the appropriate value for your sound card in the file /home/pi/.openauto/config/openauto_system.ini. You probably need to set it to MixerName=Digital
Reply
#3
@ktb, thank you very much for your contribution to the forum. We really appreciate your help.

@Frank, it would be really important to post output of either amixer scontrols or amixer comand. In 6.0 version we implemented feature that should automatically pick up a mixer to control the volume. We have tested it with many sound cards and have not observed any issues. Output of mentioned commands will help us investigate potentatial issue (either with sound card or algorithm itself).
Reply
#4
It works! I loaded "MixerName=Digital" in the .ini file and sound is now controlled. Thanks.
Reply
#5
Just curious if this would relate to my issue. I've just installed a USB video capture card for my reverse camera, and now I can't control volume. It is giving me the speaker symbol with an x next to it. I am using a USB sound card also and this has worked perfectly since I installed it.

The video capture card also has audio inputs, so wondering if this is conflicting with the primary card. Lsusb shows all usb devices connected, and sound works in AA using my radio app. Raspbian also shows no volume control options.

I'm running an RPi4 with the Mausberry 3A power supply that has the other usb port powering the RPi touchscreen. I have a separate usb power supply that is powering my powered usb hub, which has my phone and video capture card plugged into it. Only the primary sound card and Bluetooth dongle are direct connected to the RPi4.
Reply
#6
(02-27-2020, 08:39 PM)jzxpacky Wrote: Just curious if this would relate to my issue. I've just installed a USB video capture card for my reverse camera, and now I can't control volume. It is giving me the speaker symbol with an x next to it. I am using a USB sound card also and this has worked perfectly since I installed it.

The video capture card also has audio inputs, so wondering if this is conflicting with the primary card. Lsusb shows all usb devices connected, and sound works in AA using my radio app. Raspbian also shows no volume control options.

I'm running an RPi4 with the Mausberry 3A power supply that has the other usb port powering the RPi touchscreen. I have a separate usb power supply that is powering my powered usb hub, which has my phone and video capture card plugged into it. Only the primary sound card and Bluetooth dongle are direct connected to the RPi4.

It might be. Most probably ALSA detected your video capture device as a primary audio device and selected its mixer as a default one. Setting name of the mixer manually in /home/pi/.openauto/config/openauto_system.ini (it will be created once you modify any setting in OpenAuto Pro Settings menu) file should do the trick. Please post output of amixer command to figure out the correct name of the mixer.
Reply
#7
amixer gives me the below.
Code:
amixer: Mixer attach default error: Invalid argument
Reply
#8
(02-28-2020, 05:47 AM)jzxpacky Wrote: amixer gives me the below.
Code:
amixer: Mixer attach default error: Invalid argument

Looks like ALSA configuration needs to be adjusted as well. Please post output of aplay -l command.
Reply
#9
I found that by editing the .asoundrc file and changing

pcm.!default {
type hw
card -1
}

to

pcm.!default {
type hw
card 0
}

it works.
Reply
#10
(02-28-2020, 06:26 AM)BlueWave Wrote:
(02-28-2020, 05:47 AM)jzxpacky Wrote: amixer gives me the below.
Code:
amixer: Mixer attach default error: Invalid argument

Looks like ALSA configuration needs to be adjusted as well. Please post output of aplay -l command.
I am having the same issues ran aplay -l and got the following:
card 1: Device [USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)