Current version of the OpenAuto Pro is 10
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Audio problems
#1
Hi there,

OpenAuto has a problem:

The speaker symbol is crossed out and the volume cannot be edited (Raspbian and OpenAuto).

The USB microphone is also not used for calls.
The USB microphone works with Android Auto with "Ok Google".

How can I fix the problem so that the USB microphone can also be used for calls and that the speaker icon is no longer crossed out?

Audio output works.

My audio hardware:
• USB microphone
• USB sound card
• Cinch to USB converter
#2
I had to go onto the raspbian desktop to the pulseaudio controls and ensure that the correct mic and speakers were chosen there.

I think the pinned post at the top of the forum would help you too....

Default audio device was disabled to not interfere with external sound devices (like USB sound cards). In order to reenable it you must edit two files below

1. /boot/config.txt
Remove or comment line (add # at the beginning of the line) "dtparam=audio=off"

2. /boot/config.txt
Add line "dtparam=audio=on"

3. /etc/modprobe.d/raspi-blacklist.conf
Remove line "blacklist snd_bcm2835"

To configure audio devices you can use PulseAudio Volume Control tool. The tool is available in Start Menu -> Sound & Video -> PulseAudio Volume Control. Also please be aware that OpenAuto requires microphone input to work properly.


Forum Jump:


Users browsing this thread: 1 Guest(s)