Current version of the OpenAuto Pro is 10
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Version 5 and hdmi output for the sound
#1
Hi,

I have updated to version 5 from version 3.x. I was using the hdmi output for the sound and this was working good.
With the version 5 I have done the same modification than listed here : https://bluewavestudio.io/community/show...hp?tid=551

In addition I add to define sound card 0 as isntead of one in the file . asoundrc.
From there I have the sound working for all applications but I can't manage the sound directly into OAP (seen as mute).

A thread available in the forum tells to set the value for MixerName to PCM. I do not find where this variable is ? Probably the one to modify for OAP 4. But what about version 5 ?
#2
MixerName property can be set at /home/pi/.openauto/config/openauto_system.ini file. By default file is created only when you modified any OpenAuto Pro setting (otherwise it uses hardcoded default settings and file is not needed).

Mixer name depends on your system configuration. Please post output of amixer command to figure out mixer name.
#3
amixer:

Simple mixer control 'PCM',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback -10239 - 400
  Mono: Playback -3856 [60%] [-38.56dB] [on]



All good with this option, thank you !
#4
With buster, when using the hdmi output for the sound you will get two framebuffers and a small distortion of the LCD display (even with a pi3b+ what I use).
Add max_framebuffers=1  in /boot/config.txt to fix this. Then one framebuffer and hdmi used only for the audio


Forum Jump:


Users browsing this thread: 1 Guest(s)