Current version of the OpenAuto Pro is 13.1
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OAP 5, volume slider disabled
#1
Hi
New on here, got first test setup on a RPI4 with Pi Touchscreen.  Just flashed OAP5 and all work except the volume slider, vol is set to 0 with a X.  However audio works.  I can drop to raspbian and adjust volume there.  Also was able set the HiFimeDIY DAC as volume control and have it show in Raspbian but still not in OAP.
I have manually edited the MixerName to HiFimeDIY DAC in ini but no change.
Any suggestions, what have I missed?
Regards
Gordon
Reply
#2
How do you know that mixer name is HiFimeDIY? What is the output of amixer command?
Reply
#3
(12-28-2019, 01:42 AM)BlueWave Wrote: How do you know that mixer name is HiFimeDIY? What is the output of amixer command?
HiFimeDIY DAC was the name that showed up in audio settings when I dropped to Raspbian, so assumed should be that and tied up to what it is.
Just ran amixer, output;

Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right 
  Limits: Playback 0 - 110
  Mono:
  Front Left: Playback 102 [93%] [-4.00dB] [on]
  Front RIght: Playback 102 [93%] [-4.00dB] [on]
Simple mixer control 'PCM Capture Source',0
  Capabilities: enum
  Items: 'Line' 'IEC958 In'
  Item0: 'Line'
Simple mixer control 'Line',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right 
  Limits: Capture 0 - 104
  Front Left: Capture 80 [77%] [0.00dB] [on]
  Front RIght: Capture 80 [77%] [0.00dB] [on]

So am now well confused as does not seem to recognise the DAC at all?
Reply
#4
(12-28-2019, 02:49 AM)baldilocks Wrote:
(12-28-2019, 01:42 AM)BlueWave Wrote: How do you know that mixer name is HiFimeDIY? What is the output of amixer command?
HiFimeDIY DAC was the name that showed up in audio settings when I dropped to Raspbian, so assumed should be that and tied up to what it is.
Just ran amixer, output;

Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right 
  Limits: Playback 0 - 110
  Mono:
  Front Left: Playback 102 [93%] [-4.00dB] [on]
  Front RIght: Playback 102 [93%] [-4.00dB] [on]
Simple mixer control 'PCM Capture Source',0
  Capabilities: enum
  Items: 'Line' 'IEC958 In'
  Item0: 'Line'
Simple mixer control 'Line',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right 
  Limits: Capture 0 - 104
  Front Left: Capture 80 [77%] [0.00dB] [on]
  Front RIght: Capture 80 [77%] [0.00dB] [on]

So am now well confused as does not seem to recognise the DAC at all?

Try to put PCM in Audio.MixerName.

Audio.MixerName=PCM
.
Reply
#5
(12-28-2019, 07:22 AM)BlueWave Wrote:
(12-28-2019, 02:49 AM)baldilocks Wrote:
(12-28-2019, 01:42 AM)BlueWave Wrote: How do you know that mixer name is HiFimeDIY? What is the output of amixer command?
HiFimeDIY DAC was the name that showed up in audio settings when I dropped to Raspbian, so assumed should be that and tied up to what it is.
Just ran amixer, output;

Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right 
  Limits: Playback 0 - 110
  Mono:
  Front Left: Playback 102 [93%] [-4.00dB] [on]
  Front RIght: Playback 102 [93%] [-4.00dB] [on]
Simple mixer control 'PCM Capture Source',0
  Capabilities: enum
  Items: 'Line' 'IEC958 In'
  Item0: 'Line'
Simple mixer control 'Line',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right 
  Limits: Capture 0 - 104
  Front Left: Capture 80 [77%] [0.00dB] [on]
  Front RIght: Capture 80 [77%] [0.00dB] [on]

So am now well confused as does not seem to recognise the DAC at all?

Try to put PCM in Audio.MixerName.

Audio.MixerName=PCM
Thanks
That fixed it immediately.  My confusion between what seeing in Raspbian and what amixer said.
Reply
#6
I have the same issue. Please elaborate where to fix this. Tied to figure it out but no luck.
Reply
#7
(02-10-2020, 05:02 PM)Likewaan Wrote: I have the same issue. Please elaborate where to fix this. Tied to figure it out but no luck.

What version of OpenAuto Pro do you use? We suggest update to the latest version before applying any fix from this thread.

Btw. what sound card do you use?
Reply
#8
Have the latest version 6 installed. Installed for first time on Sunday. Volume on drop down is dead also on Raspbian it shows a X on sound output on task bar. Not too sure about sound card but I do have sound. Just no adjustment on screen. Only on radio itself. Will confirm Sound card.
Reply
#9
What sound card do you use? What is the output of amixer command?
Reply
#10
ummm sorry stupid question where do I check that?

Attached picture of sound card. so Idea of brand or so its one that was in the cupboard.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)