Current version of the OpenAuto Pro is 6.1
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenAutoPRO 4.0 Volume Handling
#1
Would anyone know how openautopro operates in regard to volume control?

Within the openautopro application, the volume control at the top of the screen I presume is remotely controlling ASLA mixer? was it previously controlling PulseAudio volume levels?

I ask as I use a Hifiberry Digi+ with an external USB microphone and have had working audio, volume control, etc with versions 3.3.2b2 and previous versions no worries.

I flashed an SD card with the latest version 4.0 and found the volume slider at the top of the screen now sits a 0 and isn't adjustable. 
Previous versions of Openautopro (3.3.2 b2 backward), the volume slider worked perfectly with the sound card configuration I have.

I do have perfect audio quality output and the soundcard is working great. 
I can adjust the volume level in pulseaudio perfectly with the latest Openautopro 4.0 image as well.

The next idea I had was to look at trying to use softvol in .asoundrc
2001 Lexus LS430 Sedan
RPi3 B+, 10" HDMI Capacitive Touch Screen, HifiBerry DAC Digi+, Audiotechnica Microphone, Arduino Mega Climate Control Integration & Air Suspension
Custom Climate Control Interface, Custom Air Suspension Interface, Custom Vehicle Lighting Interface
Reply
#2
OpenAuto Pro uses ALSA mixer to control volume level. There should be a PCM/Master/Speaker mixer exposed by ALSA. If there is no mentioned mixer available you should adjust .asoundrc configuration file. Most probably it is required to adjust card index as HiFiBerry uses different driver.
Reply
#3
I have the same problem with a piano DAC. I managed to make the DAC the default card, still the Volume bar in Open Auto is not functional. Which channel of alsamixer is controlled by that bar?
Did you find a solution to this? If you edited your .asoundrc, can you post the file? Thanks!
Reply
#4
So I tried some things today. My DAC is set default, still as you suggested there is no Master or PCM channel. The channel that controls audio volume is called via the DAC "digital".
I see two options here:

1. Somehow create a new channel in alsa that is linked to the digital channel. That must be possible somehow, just need some research how to. In this case it would be nice to know which alsa channel is controlled by the volume slider in Open Auto Pro.

2. Change the channel that is controlled by the Open Auto Pro volume channel to "digital". In that case it would help to know where to look in Open Auto Pro configuration.

To be honest I think puleaudio was the better way to go with Open Auto Pro as the abstraction layer is high enough it doesn't care at all about hardware. What was the reason switching to alsa?
Reply
#5
(12-21-2019, 06:59 PM)miro279 Wrote: To be honest I think puleaudio was the better way to go with Open Auto Pro as the abstraction layer is high enough it doesn't care at all about hardware. What was the reason switching to alsa?

PulseAudio volume controls may produce many distortions during volume changes. This is the reason why we control volume level via ALSA. In next release we will consider new configuration option to set name of the mixer.
Reply
#6
Ok, I'll try to create a new alsa channel than. Do you use the "Master" channel for volume changes?

I found this: https://support.hifiberry.com/hc/en-us/a...me-control

will try it soon and post if I was successful.
Reply
#7
I have been battling with this now for 2 days myself. I have setup ALSA 'softvol' via every conceivable way I could find online. However it makes no difference.
There is no softvol created option in alsamixer, amixer, nothing. Its like Raspbian Buster has no idea what softvol is?

I was poking around on a older image file (3.3.1) and it looks like it was directly controlling volume via pulse audio originally. Can you please guide us on how to do this again? I have found files : pulse.conf and pulse-alsa.conf but they make no difference when used in /usr/share/alsa folder.

uugghh every previous version to 4.0 I have had ZERO issues with the Hifiberry and volume control. Feeling so frustrated right now.
2001 Lexus LS430 Sedan
RPi3 B+, 10" HDMI Capacitive Touch Screen, HifiBerry DAC Digi+, Audiotechnica Microphone, Arduino Mega Climate Control Integration & Air Suspension
Custom Climate Control Interface, Custom Air Suspension Interface, Custom Vehicle Lighting Interface
Reply
#8
(12-22-2019, 01:21 PM)Digitalmick Wrote: I have been battling with this now for 2 days myself. I have setup ALSA 'softvol' via every conceivable way I could find online. However it makes no difference.
There is no softvol created option in alsamixer, amixer, nothing. Its like Raspbian Buster has no idea what softvol is?

I was poking around on a older image file (3.3.1) and it looks like it was directly controlling volume via pulse audio originally. Can you please guide us on how to do this again? I have found files : pulse.conf and pulse-alsa.conf but they make no difference when used in /usr/share/alsa folder.

uugghh every previous version to 4.0 I have had ZERO issues with the Hifiberry and volume control. Feeling so frustrated right now.

There was no change in volume control between 3.3.1 and 4.0. The only difference is Raspbian version (Stretch vs Buster) where handling of hifi berry might be changed. We suggest to ask for support on the HiFi Berry forum as OpenAuto Pro bases on default Raspbian configuration.
Reply
#9
All, 

I came here looking for help with non functional volume slider in OpenAuto 5.0. My volume slider is at minimum and will not move. Mute is indicated as active as well. I was able to change the volume at pavucontrol. I am using a USB Sound Blaster for audio and a USB mike. I reflashed the image of 5.0 twice. If someone can offer up some advice. I am not using hifi berry.

Thank You.
Reply
#10
I tried to setup softvol today es well, unfortunately without success. I followed intructions from alsa: https://alsa.opensrc.org/How_to_use_soft...ter_volume



When tried the pcm created I always get "Device or resource busy".



The setup looked like this in /home/.asoundrc:



Code:
pcm.softvol {
    type            softvol
    slave {
        pcm         "hw:0,0"
    }
    control {
        name        "Master"
        card        0
    }
}

pcm.!default {
    type            asym
    playback.pcm {
        type        plug
        slave.pcm  "softvol"
    }
    capture.pcm {
        type        plug
        slave.pcm  "hw:1,0"
    }
}

Where hw:0,0 is the DAC and hw:1,0 the usb microphone..


No idea whats the problem here. Maybe I also try to setup puleaudio again, if packages are installed that could work and also result in a single Master Volume control..
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)