Current version of the OpenAuto Pro is 6.1
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Phone call comes through phone
#1
Possible bug, but when using either internal or an external BT adapter, no phone call audio goes through OAP, just through the handset. I have initiated the BT connection from both the pi and the phone, Ive used an external adapter that supports hfp (and done sudo btswitch external). Music/contact sharing etc. works fine over Bluetooth, just not calls.

OAP Version: 3.3.2 v2

Hardware:

Raspberry Pi 4
OnePlus 5T - Lineage OS 16.0
Reply
#2
Please try to unpair your phone and RPI then execute following commands:

Quote:sudo apt-get purge bluealsa -y
sudo reboot

Then please pair your phone again and see if that helps.
Reply
#3
Hello, I have the same issue.

Version: 
Beta Openauto Pro 3.3.2 b2

I'm using an external bluetooth dongle:
https://www.amazon.com/Avantree-Bluetooth-Computer-Keyboard-Warranty/dp/B00VWEK4IG/ref=sr_1_1?__mk_de_DE=%C3%85M%C3%85%C5%BD%C3%95%C3%91&keywords=Avantree+DG40S&qid=1569233428&s=gateway&sr=8-1

This bluetooth adapter is not using the Broadcom chipset.

I have tried:


Code:
sudo apt-get purge bluealsa -y
sudo reboot


Also executed the command for using the external bluetooth adapter.
But also no fix.

Should I just create an own thread?
Reply
#4
(09-23-2019, 10:17 AM)prinzpi Wrote: Hello, I have the same issue.

Version: 
Beta Openauto Pro 3.3.2 b2

I'm using an external bluetooth dongle:
https://www.amazon.com/Avantree-Bluetooth-Computer-Keyboard-Warranty/dp/B00VWEK4IG/ref=sr_1_1?__mk_de_DE=%C3%85M%C3%85%C5%BD%C3%95%C3%91&keywords=Avantree+DG40S&qid=1569233428&s=gateway&sr=8-1

This bluetooth adapter is not using the Broadcom chipset.

I have tried:


Code:
sudo apt-get purge bluealsa -y
sudo reboot


Also executed the command for using the external bluetooth adapter.
But also no fix.

Should I just create an own thread?

Could you please try to reproduce the issue with the latest version (3.3.2 RC1)? What Raspberry PI are you using?
Reply
#5
(09-23-2019, 07:50 PM)BlueWave Wrote: Could you please try to reproduce the issue with the latest version (3.3.2 RC1)? What Raspberry PI are you using?

I'm using RPI 4.
I'll try your suggested version.

Update: 
Same result with the 3.3.2 RC1 version, phone calls are just going throug the phone.

Steps I have done:
1. Flashed new 3.3.2 RC1 image
2. Set "Local" inside the BT settings
3. Executed the command to switch to the external BT adapter
4. reboot
Reply
#6
On my setup with the 1+6T I have to go into the bluetooth setting for openauto on the phone and share media audio, contact sharing, phone calls.  This is a slider on or off. i would check this setting.
Reply
#7
(09-24-2019, 12:13 PM)jennmike2 Wrote: On my setup with the 1+6T I have to go into the bluetooth setting for openauto on the phone and share media audio, contact sharing, phone calls.  This is a slider on or off. i would check this setting.

Yes, all these options are on.
Regards.

btw: I'm using Note 10+
Reply
#8
@prinzpi Could you check if you get any errors during execution of Bluetooth switch script?
Reply
#9
Have upgraded today to the 3.3.2 rc1 version, have got a new phone now (op5t -> xiaomi mi 9t pro) and still not getting any audio for the phone call. Instead of straight playing out of the speakerphone now, the phone says the call is routing through the openauto bluetooth, but no sound comes out from anywhere.

When running `sudo btswitch external` there are no errors in the terminal, is there a log file for this anywhere (or would the errors just display when running the script)?
Reply
#10
All errors are visible during script execution. Our test reference was Mi8, RPi4 and external BT dongle. What dongle do you use?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)