Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Is there any full helpy document for connecting reverse cam?
#11
I have tried your hardware as well, still need the same part of information you do. For now I have a RPI cam set up with an HDMI converter from the ribbon. using a cheap 25 foot Hdmi cable. Then to same converter to the ribbon then the camera. and with the latest version of open auto I use the button. No config nessary. The cam sits in rear window as I have yet to find a water proof case. I like that I'm not restricted to using only reverse to turn it on.

But there is a thread I saw on here. Try googling the topic / Bluewavestudio.io. I wanna say he has an youtube video that has a link to his code. his name starts with H. sorry I dont remember your name if you see this. Smile
Reply
#12
Ribbon cables are generally designed for carry low energy in short length. Extending the ribbon cable may be lower the productivity of image quality also maybe this cause receive image problem from camera. If you receive, thats good. But in this case there will be another problems. One of these is like you told, how to cover camera from outside effects.

The shortest, cheapest and healty way is standart rear cams I think.

My job is video industry. Im working in a company which is working on conferencing, decode-encoding video, streaming etc.

Ffmpeg and ffplay is the most useful libraries in video encoding and decoding operations.

I believe in we can receive image from RCA cam with ffplay. I have done it before in medical industry with recieving image from endoscopy and medical cameras which has SDI output. We was converting analog video output to the h264 to stream in web.

When I bought camera and easycap I can share this code for receive image from camera with ffplay.

When you run the ffplay command with options ffplay opening own screen and playing video in this screen.

We can save an batch file which included this ffplay code.

But engineering first rule is : If someone done a work with easiest and best way, do not touch. If had not created, do it with known best and easiest way if you dont have a better idea.

Grabbing video is not a scientsic impovement Big Grin

By the way I'm very busy due the works. So, I could not work on this topic these days.

I believe someone will done this work with successful Big Grin
Reply
#13
(09-22-2019, 07:38 PM)kirikoglu Wrote: Ribbon cables are generally designed for carry low energy in short length. Extending the ribbon cable may be lower the productivity of image quality also maybe this cause receive image problem from camera. If you receive, thats good. But in this case there will be another problems. One of these is like you told, how to cover camera from outside effects.

The shortest, cheapest and healty way is standart rear cams I think.

My job is video industry. Im working in a company which is working on conferencing, decode-encoding video, streaming etc.

Ffmpeg and ffplay is the most useful libraries in video encoding and decoding operations.

I believe in we can receive image from RCA cam with ffplay. I have done it before in medical industry with recieving image from endoscopy and medical cameras which has SDI output. We was converting analog video output to the h264 to stream in web.

When I bought camera and easycap I can share this code for receive image from camera with ffplay.

When you run the ffplay command with options ffplay opening own screen and playing video in this screen.

We can save an batch file which included this ffplay code.

But engineering first rule is : If someone done a work with easiest and best way, do not touch. If had not created, do it with known best and easiest way if you dont have a better idea.

Grabbing video is not a scientsic impovement Big Grin

By the way I'm very busy due the works. So, I could not work on this topic these days.

I believe someone will done this work with successful Big Grin


Just thought I should add my ribbon cables are only 2 inches long. They go to an HDMI converter board. the long cable is the HDMI.
https://www.amazon.com/gp/product/B06XDNBM63/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1
Reply
#14
(09-21-2019, 01:03 PM)Daniel_BlueWave Wrote: "Plug and Play or easy to configure." - this is Linux. Are you able to configure your camera in Raspbian OS? You should ask manufacturer for more information how to do that.
The camera works in VLC with my Easy Cap device. I open "Capture Device" and set the "Video device name" to /dev/video0 and it works fine. What settings do I need to change to get it to work in Open Auto?
Reply
#15
(09-25-2019, 02:19 PM)officialgrantd Wrote:
(09-21-2019, 01:03 PM)Daniel_BlueWave Wrote: "Plug and Play or easy to configure." - this is Linux. Are you able to configure your camera in Raspbian OS? You should ask manufacturer for more information how to do that.
The camera works in VLC with my Easy Cap device. I open "Capture Device" and set the "Video device name" to /dev/video0 and it works fine. What settings do I need to change to get it to work in Open Auto?

In RC1 version there is an entry in openauto_system.ini file to set name of the device. /dev/video0 is the default one so it might not be necessary to edit config file at all.
Reply
#16
(09-25-2019, 02:23 PM)BlueWave Wrote:
(09-25-2019, 02:19 PM)officialgrantd Wrote:
(09-21-2019, 01:03 PM)Daniel_BlueWave Wrote: "Plug and Play or easy to configure." - this is Linux. Are you able to configure your camera in Raspbian OS? You should ask manufacturer for more information how to do that.
The camera works in VLC with my Easy Cap device. I open "Capture Device" and set the "Video device name" to /dev/video0 and it works fine. What settings do I need to change to get it to work in Open Auto?

In RC1 version there is an entry in openauto_system.ini file to set name of the device. /dev/video0 is the default one so it might not be necessary to edit config file at all.
I have RC1. I looked at the config file and it is set to /dev/video0 as expected. It works in VLC but not in OAP
Reply
#17
(09-25-2019, 02:27 PM)officialgrantd Wrote:
(09-25-2019, 02:23 PM)BlueWave Wrote:
(09-25-2019, 02:19 PM)officialgrantd Wrote:
(09-21-2019, 01:03 PM)Daniel_BlueWave Wrote: "Plug and Play or easy to configure." - this is Linux. Are you able to configure your camera in Raspbian OS? You should ask manufacturer for more information how to do that.
The camera works in VLC with my Easy Cap device. I open "Capture Device" and set the "Video device name" to /dev/video0 and it works fine. What settings do I need to change to get it to work in Open Auto?

In RC1 version there is an entry in openauto_system.ini file to set name of the device. /dev/video0 is the default one so it might not be necessary to edit config file at all.
I have RC1. I looked at the config file and it is set to /dev/video0 as expected. It works in VLC but not in OAP

Please put the same parameters as for VLC.
Reply
#18
(09-25-2019, 02:40 PM)BlueWave Wrote:
(09-25-2019, 02:27 PM)officialgrantd Wrote:
(09-25-2019, 02:23 PM)BlueWave Wrote:
(09-25-2019, 02:19 PM)officialgrantd Wrote:
(09-21-2019, 01:03 PM)Daniel_BlueWave Wrote: "Plug and Play or easy to configure." - this is Linux. Are you able to configure your camera in Raspbian OS? You should ask manufacturer for more information how to do that.
The camera works in VLC with my Easy Cap device. I open "Capture Device" and set the "Video device name" to /dev/video0 and it works fine. What settings do I need to change to get it to work in Open Auto?

In RC1 version there is an entry in openauto_system.ini file to set name of the device. /dev/video0 is the default one so it might not be necessary to edit config file at all.
I have RC1. I looked at the config file and it is set to /dev/video0 as expected. It works in VLC but not in OAP

Please put the same parameters as for VLC.
i have the same issue... V4L2:///dev/video seems to be the parameter and i have that in the config file but doesnt trigger the camera... when i run DISPLAY=0: cvlc v4l2:///dev/video0 from the command line i do get the video feed on the HDMI display
Reply
#19
The parameters in the config file are the same. I even tried getting rid of the V4L2:// since VLC just has /dev/video0 but that didn't work either. What should we try next?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)