BlueWave Studio forum
Warped video in Android Auto - Printable Version

+- BlueWave Studio forum (https://bluewavestudio.io/community)
+-- Forum: OpenAuto Pro (https://bluewavestudio.io/community/forumdisplay.php?fid=86)
+--- Forum: Android Auto (https://bluewavestudio.io/community/forumdisplay.php?fid=79)
+--- Thread: Warped video in Android Auto (/showthread.php?tid=656)



Warped video in Android Auto - Makabay - 01-03-2019

Hello,



having installed OpenAuto Pro 3.0, everything seems to work great except for an issue where the video output coming from my Android device is massively warped. As soon as I plug my phone in OpenAuto correctly seems to switch to displaying the Android Auto homescreen. However, that homescreen is completely warped, using only roughly the left half of the screen and extending downwards beyond the screen area.

[img]https://i.ibb.co/4T1v7BN/IMG-20190103-233111.jpg[/img]



The display I use is a 5.9" Manga Screen 2. That screen has a native resolution of 1080x1920 (it is a portrait-format screen), which I run rotated (using display_rotate=3 in my config.txt file). I also run a small amount of overscan because the edges of the screen aren't visible in my housing.



I would appreciate any help with this. Thank you for the awesome product!



Re: Warped video in Android Auto - BlueWave - 01-03-2019

Hello,
Try to set (in /boot/config.txt) framebuffer_width and framebuffer_height parameters accordingly to the display rotation, e.g.
framebuffer_width=1080
framebuffer_height=1920

Also please note that according to the Raspberry PI documentation (https://www.raspberrypi.org/documentation/configuration/config-txt/video.md), display_rotate option is deprecated.


Re: Warped video in Android Auto - Makabay - 01-04-2019

Thanks for the help. I have changed display_rotate to display_hdmi_rotate and added framebuffer_width and framebuffer_height parameters, but the problem persists. Everything looks correct until I plug my phone in, then the video stream from the phone is warped.



I'm not sure whether it helps debugging, but I have previously used Crankshaft and the problem did not occur there.



Re: Warped video in Android Auto - BlueWave - 01-05-2019

Could you please try to disable "Show top bar in Android Auto" option (Appearance settings) and see how it behaves?



Also please try to set framebuffer settings to width=1920 and height=1080.



Re: Warped video in Android Auto - Makabay - 01-05-2019

Thanks for the advice - disabling "Show top bar in Android Auto" fixes the issue!