BlueWave Studio forum
RPI touchscreen not calibrated - Printable Version

+- BlueWave Studio forum (https://bluewavestudio.io/community)
+-- Forum: OpenAuto Pro (https://bluewavestudio.io/community/forumdisplay.php?fid=86)
+--- Forum: User interface (https://bluewavestudio.io/community/forumdisplay.php?fid=66)
+--- Thread: RPI touchscreen not calibrated (/showthread.php?tid=2033)



RPI touchscreen not calibrated - Hoedie - 09-17-2020

I'm having trouble with the latest version of OpenAuto which I bought 3 days ago.

My setup is a Raspberry PI 3B+ and an official raspberry 7" touchscreen.


When I install the latest Rasbian version the touchscreen is fully functional, however with the latest version of OpenAuto the touchscreen isn't calibrated correctly. The application displays in full screen, but the touchscreen input is compressed to half of the screen (left half is working, right half isn't responding). For example, when I want to push a button on the top right of the screen I have to press on the top middle of the touchscreen.

My guess is the xinput isn't calibrated correctly, so I tried installing xinput, however while calibrating I can touch the entire screen but the display streches to 14" which is out of bound.

Does anybody recognize this?


RE: RPI touchscreen not calibrated - BlueWave - 09-17-2020

It is known issue of Raspberry PI 3. Please try to change max_framebuffers=2 to max_framebuffers=1 parameter (all occurences) in /boot/config.txt and post the result.


RE: RPI touchscreen not calibrated - remskiller77 - 10-12-2020

Thanks it works