BlueWave Studio forum
No Phone audio over BT - Printable Version

+- BlueWave Studio forum (https://bluewavestudio.io/community)
+-- Forum: OpenAuto Pro (https://bluewavestudio.io/community/forumdisplay.php?fid=86)
+--- Forum: Audio features (https://bluewavestudio.io/community/forumdisplay.php?fid=63)
+--- Thread: No Phone audio over BT (/showthread.php?tid=1212)

Pages: 1 2


No Phone audio over BT - dlooper - 11-09-2019

Hi, 

Raspberry pi 4
USB Bluetooth
Sound Blaster Play 3 usb sound card

I have a weird issue. All audio works except the phone audio out. In a call, the person on the other end can hear me but theres no audio coming back through the pi. I know the mic and speakers work because music and voice commands through AA/OAP all work fine. Everything was working before i switched from a Sound Blaster Play 2 to a Sound Blaster Play 3. But, like i said the only thing that isnt working is the phone call audio coming in. 

Is there a file somewhere that maps bluetooth audio in to a device attached to the pi or something that may be causing this?

On a side note, i have looked through the /var/log/syslog and i see a lot of errors regarding bluetooth.


RE: No Phone audio over BT - aausten - 12-03-2019

Hi,

Did you ever resolve this issue as I have the same problem? I have the same setup except I have a cheap USB sound card.

If I use the internal soundcard rather than a USB one then the phone audio does work. I thought about using the internal sound for output and USB for just the microphone input but haven't figured out how to get that to work either. I'd prefer to use the external card for both.

Also have the issue whether I use the internal or external bluetooth.


RE: No Phone audio over BT - Daniel_BlueWave - 12-03-2019

Those issues seems to be related to BT more than sound card. Does music streaming work? Did you check HFP with other dongle? There is also possibility to activate internal sound card: https://bluewavestudio.io/community/showthread.php?tid=551


RE: No Phone audio over BT - aausten - 12-04-2019

Yes music streaming over bluetooth works and I have tried with different dongles, now using the Plugable one and have updated the firmware as suggested in another thread.

The fact that the phone audio works through the internal soundcard when USB one is disconnected suggests to me that it is related to how the phone audio output is handled.

I will try again to use the internal card for output but USB for input.


RE: No Phone audio over BT - aausten - 12-04-2019

Ok, so I've managed to get it to work but I'm not really sure how, more luck than skill.


RE: No Phone audio over BT - Viper - 12-04-2019

(11-09-2019, 08:08 PM)dlooper Wrote: I know the mic and speakers work because music and voice commands through AA/OAP all work fine. Everything was working before i switched from a Sound Blaster Play 2 to a Sound Blaster Play 3. But, like i said the only thing that isnt working is the phone call audio coming in. 

Hello,

I have had the same issue with the Soundblaster Play3 and couldn't fix it. With a cheap USB Sound Card now everything works. When you can fix it please wrote it here. I would like to use my Soundblaster instead of the cheap one...


RE: No Phone audio over BT - BlueWave - 12-04-2019

We suspect that problem is related to the USB 3.0 implementation (high-speed devices) in Raspberry PI 4. That may explain why HFP works with internal sound card. Do you observe any differences when Bluetooth dongle and sound card are connected to different porta?


RE: No Phone audio over BT - Viper - 12-05-2019

(12-04-2019, 05:21 PM)BlueWave Wrote: We suspect that problem is related to the USB 3.0 implementation (high-speed devices) in Raspberry PI 4. That may explain why HFP works with internal sound card. Do you observe any differences when Bluetooth dongle and sound card are connected to different porta?

I have a RPI3B+ and the same issue.


RE: No Phone audio over BT - BlueWave - 12-05-2019

(12-05-2019, 06:49 AM)Viper Wrote:
(12-04-2019, 05:21 PM)BlueWave Wrote: We suspect that problem is related to the USB 3.0 implementation (high-speed devices) in Raspberry PI 4. That may explain why HFP works with internal sound card. Do you observe any differences when Bluetooth dongle and sound card are connected to different porta?

I have a RPI3B+ and the same issue.

It might be an issue related to your Dongle then.


RE: No Phone audio over BT - Frank - 12-27-2019

Running OAP 5.0 on pi 4b.  Need another idea to solve this.  On phone calls, outgoing does go through microphone. But the reception is directly to the phone and not through OAP /AA.  Just to be sure, both mic and BT usb are plugged into usb 2.0.  I need to double check BT setting in OAP.  Should it be "none", "local" or "remote"?  I dont think my sound card is involved in this issue. It plays everything else I throw at it.

UPDATE: My issue is resolved.  I upgraded my pi from 3B+ to the 4b.  I didn't pay any attention to the Bluetooth handshakes between pi and phone.  Turns out, old link does not work on new pi.  Once I erased the old links and set up new links to the phone and new pi 4b, everything worked.